Media Bay doesn't list edited attributes

In Cubase Artist 12 I added attributes to my samples, first I tried to add ‘Library Name’, but the Attribute filter did not list theses added ones and later, when I retagged all the samples with ‘CD Name’ attributes, this does not work either. Next to the files the tagged value is present, but the filter does not pick up the values. (see screenshot)

Surprisingly, other added attributes (Genre, Category, etc.) work ok, even though these are customized as well.

Deleting and rebuilding the media bay database did not help.

Windows 11, the samples are on a removable drive.

Any help is welcome

Can you try opening sample in notepad or any txt/hex editor and scroll all the way down and see if the tag is written into the wave file?

I personally don’t use “CD name” tag group so maybe it’s specific to that tag.

As workaround you can make your own custom tags so basically just made the similar CompacDisc name custom tag group and than make tags u need for particular samples.

I am able to do this on my system. (meaning I do not have the problem you described)

Could you possibly supply a screenshot of the whole window with every pane and option showing, rather than simply illustrating only what you have described in text?

For the right zone, be sure to include both dynamic tab and defined tab.

Dear Helpers
Here is the end of a wave file, opened with text editor:

As I can see, the attributes are listed here
Here is a full screenshot of the Media Bay:

and another:

Some test results:
If I put a folder onto the C drive, the problem disappears. Both the C drive and the D drive version of the samples get picked up(!) When I delete the C drive copy, the samples do not get picked up again from the D drive location.
Custom attributes do not help (in the picture 'sampleLibrary@ is a custom tag.
I tried Volume database, no result.
As you can see the D drive is a SD card. The machine is a Surface Pro 6, running Windows 11. Everything is with the latest updates.
Thank you for your kind help. :slight_smile:

Interesting, So when its on solid disk its ok as I understand well? Can you try samples on flash drive? Or better external HDD/SSD drive?

Can you upload 2 samples from different manufactures (in your case Lib Name/Cd Name) so I can check here.

As Steve said it seems works ok for him and if I confirm the same its probably that SD card/System related.

Here are some more test results:
Using a Flash drive does not bring different results.
After copying samples onto a flash drive and scanning them with Media Bay:

The attributes are clearly there, but the filter does not pick them up.
However, if I change one of the attributes, the changed files get picked up by the filter (adding ‘_x’ to the Library name):

And the same happens on the original location (Drive D):

However, after restarting Cubase, the filter does not pick the values again.

Instead of system issues, I would rather suspect the fact that these samples were originally tagged on a Cubase Elements 11. This version allegedly cannot do this, however it was possible to add attributes to the samples and sometimes they were picked up by the filter, sometimes not. I guess the removing of this function somehow crippled the attributes and this might have an effect on Artist too. (as I mentioned, the deleting and rebuilding the database did not help.) By the Way, the Elements version is still installed on the computer.
Help is still requested.

Here are two of the samples: (2.0 MB)

Weird problem

Still can’t reproduce it.

The tags showed up in the Attribute list. I did hit Rescan Disk, this is typically needed.

I edited one of the tags in an attempt to screw things up, without success.

Seems all good here, maybe on big scale there is some issues. To rule out some things try following:

  1. Try on these 2 files you sent and see if it works. If yes
    Than try to add folder by folder (cd name one at the time) scan as Steve said (not quick scan)
    and see if it get stuck at some point as you adding, maybe there is some incompatible library. I had some issues that I had to batch re-save waves for one of the libs in order to fix it (i think was something with tags)
  2. If not you have to try it on different system and different computer. In my career only way to solve some issues was just reinstalling the system (which is the last and desperate option to try lol)

Good luck

Dear All, thank you for your efforts.
Of course I tried adding the files separately, they do not show up. The only way is to make them show up is to edit a parameter, then the files miraculously appear, until I close Cubase, because after a restart everything disappears again.
I very strongly suspect that to in order to remove the custom tags editability form the Elements version, the Steinberg engineers opted for implementing a ‘do not pick this file into the filter’ attribute, which prevented the files to be picked up. Unfortunately, this attribute is still interferes with the Artist version, so maybe even a complete reinstall would not be of help.
A possible solution might be to acquire these files again and tag them from the absolute scratch, however it is just as complicated as tedious…
Of course, this is all speculation.