loading an instrument in kontakt or superior drummer i got that message saying “memory running low”.
so i watched my ressource on the performance window of window7 and this is what i have :

total 16367
cache memory 6805
available 9180
free 2535

and watching the process tab i read
Nuendo 3 Go.
Vienna ensemble 2.2Go

so that’s 5.2Go only
why do i have so much cache memory ? what is it for ? is there a way to raise the free memory ?

here is my setup :
i72600k (4.5Gz) / 16Go / windows7(64) / cubase 6.0.0 (64) / ssd drive 250Go /

for the samples i have :
kontakt 4.2.2 (64) / SupDrum2 (64) / vienna ensemble (64) /

2.5 Gb of free memory should not have given you that message.
16 Gb is more then enough.
The fact you get the message is more of an indication you are running Superior drummer at 32 bit instead of 64 bit because 32 bit applications can’t access memory above 3120Mb.
Are you sure there isn’t a 32 bit version of superior drummer on your system somewhere which is running inside Cubase?
Check the plug-in information in Cubase and find out what it says for superior drummer in the column “SDK”.

no it says VST2.4 on superior drummer (no 32bit sign)
i tried to load 2 instance of superior (with nocache inside superior so 1024of ram) and i get the message from superior :
“Memory limit exceeded”

when i get thismessage the process of windows7 says :

cache memory 6267
available 8112
free 1949

i bougth the jbridge for some plugs i have that doesn’t work on 64 … would that be a problem ?

Jbridge is designed to overcome the memory limit for 32 bit plug-ins so it’s very unlikely that’s the problem.

However you did not specify the exact version of superior drummer.
There was a bug in superior drummer resulting in spurious prompts that the memory limit was exceeded (MemLoaded-6383 bug).
This bug was fixed in version 2.2.0 and the current version is 2.2.3.

i’m using the superior 2.2.3.
but i also got that message while loading an instrument in kontakt 4.2.2
so it might have something to do with how my ram is used maybe in windows…
don’t you think 6.8Go of memory cache is big ?

No, i don’t think 6.8Go of memory cache is big.
Windows will only use memory for cache when there is no other demand for that memory.
In stead of unused memory being wasted Windows fills it with data likely to be needed from the disk.
The more memory you put in your comp the more Windows will use for caching.

The only other thing i can think of which might cause a problem is the level of the pagefile (virtual memory)
Even with ample available memory Windows will show some degree of pagefile usage.
Now some programs track the pagefile usage and report memory shortage on it.
Therefor it’s a bad idea to restrict the virtual memory (people tend to do this because they think they don’t need it when they have lots of memory).
I find setting it to automatic to be best but a good rule is to have double the amount of normal memory set for the maximum of virtual memory.

BTW, what was the exact error message for kontakt?

Do you have the RAM limit set high enough in Superior? Some of the full kits with presets are larger than the default 1200. Try raising it to something like 2000. Not familiar with Kontakt. Just a thought…

well i was tryping to load instruments in kontakt to get that message but cubase crashed before :stuck_out_tongue:

free memory was around 0. the more i was loading samples the more memory cache went done for about 200Meg to 8Go)
but then i put Liberis instrument Full and boom.
i set superior to 3Go in case.
i’ll try again :stuck_out_tongue: