Metronome in Cubase 12 being out of sync with the Matrixbrute sequencer

Hi all , my first post. Been using Cubase pro 12 for 6 months and it’s been great. I recently purchased the Matrixbrute . Everything is working great apart from the metronome in Cubase 12 being out of sync with the sequencer, just the slightest we bit. The delay compensation on Cubase 12 doesn’t make a difference what way you move it, Tho it works for my other hardware. All other midi is working 100%. I have posted on Arturia forum as well but thought I would try here also. Thanks Jamie

Hi and welcome to the forum,

How do you sync Matrixbrute with Cubase, please?

Hi Martin thanks for replying. I am connected through USB at the moment. The Wavestate is also not in sync through USB. I have recorded MIDI notes from the sequencer on the Matrix and they are perfectly aligned in Cubase. It does seem that the metronome is out by a very small margin, even when I run a plug-in like Diva, as I just tried it there now and its out ever so slightly. I am not sure whats going on. Thanks Jamie

Hi,

Do you use any sequencer or arpeggiator in the Matrixbrute? If yes, you have to really sync it with Cubase. You have to use the Project Synchronization Setup > Destinations and send the MIDI Clock to the hardware. Then you have to set the hardware as Slave device.

I have been trying to sync the sequencer. It is out my a slight fraction . I have adjusted every setting I can think of from matrixbrute and Cubase. Nothing has made a difference. I have removed USB connection and hooked up through midi cable, problem is still the same. It is the same problem for the Wavestate. As I said it will record midi information from the matrixbrute sequencer perfectly .

Maybe I should take photo’s of my current settings and you can have a look. But I have adjusted every setting everyway hehe.

Thanks for replying Martin

here are my current settings and matrix is connected through USB.

I can only post 1 photo at the moment

these are current settings but have changed them many times and nothing has worked as yet. thanks

Hi,

Did you setup the hardware as Slave on the hardware itself, please?

The only settings on Matrixbrute are these? There is a midi sync button on the Matrix and it suppose to link through USB.

Hi,

I believe the options and the meaning will be described in the manual of the hardware.

I have linked the Novation Peak up and both that and the matrixbrute is recording audio with a slight dely just before a midi note is triggered. Or sometime just after like in this image. As you can see the there is a delay in the recording .

I have adjusted all the settings in the midi centre and nothing has worked. Also it’s not limited to Matrixbrute. Novation peak is slightly out as well over USB. Pc specs are i7 9600k , 32 gig ram, all on ssd’s , windows 10 etc. Thanks

Can I suggest that you close the other apps on your machine, particularly photoshop.
it is possible that they are making calls on your audio system that are not helping matters.

If you use the sequencer/synth as just originally usb-MIDI clock slave and audio inputs, the midi sync messages will have latency added. Try using it as an external instrument and send sync to the external instrument not to the physical port. This way the midi clock will be earlier and will be in sync with cubase transport.