Metronome playing same sound on all beats

I have tried extenisvely all settings I can find to solve this and searched all forums but found nothing.
It used to work fine but I had to delete my defaults.xml as I had a bug of marker handles not dragging (then fixed).

The issue is that the metronome sound being played is only the ‘Hi’ sound on all 4 bars whereas it should play the ‘Lo’ on beat 1 as default.
I confimed this by turning the Hi & the Lo volumes down and only the Hi makes a difference and on all 4 beats.
I’ve tried MIDI and Audio and no difference. I’ve checked that the sounds are entered differently for hi & low (MIDI instrument & Audio frequencies)

Is there a preference somewhere I am missing please that maybe I changed by mistake?
I’m fairly sure I haven’t as I only recently deleted my Defaults.xml returning my prefs. to factory settings and I can’t remember changing any metronome settings.
Actually, I’ve just noticed that on one project it is working fine and another it is not so I guess it’s within the song rather than global settings but all metronome settings are identical. What’s frustrating is that I’ve set/saved my main template using the song with the fault?

Hoping one of you geniuses can help.

Further to above, I notice when extending the metronome toolbar that it shows that the pattern is wrong - just 1 single straight line whereas other songs have 2 lines showing 1st beat on hi and other 3 beats on low but I can’t seem to change the pattern in the pattern settings. Whatever pattern I click on doesn’t make any difference. Is there a special key command I should be doing that the manual isn’t telling me?

Hi,

Could you attach a screenshot of your Metronome Setup > Click Sounds window, please?

Hi again Martin,

Thanks for you kind attention.
Please find screenshots attached.



Hi Martin,
I just added a signature track which revealed that my signature was set somehow as 1/4 hence all 4 beats being the same click and I was able to double click on the 1/4 in the project window on the signature track and change the 1 to a 4 (1/4 to 4/4) which solved the problem of course.
However, this should have been possible in the ‘click pattern’ dialogue window but whatever I click on doesn’t change the setting in the song/project window, signature track. I can get by with this but can you advise what I am supposed to click on in the patten selection window and whether it works for you?

Thanks in advance.

Hi,

In the Pattern Selection window, you just choose the pattern you want to use for the current Time Signature in the project (in the given time). For example for 4/4 you can have paternities like Hi-Lo-Lo-Lo or Hi-break-Lo-Lo or Hi-Lo-Lo-Hard or whatever. The pattern helps you with the feeling of your rhythm while recording.

Hi Martin,
I fully get that but unfortunately as mentioned above “ whatever I click on (in the same 4/4) doesn’t change the setting in the song/project window, signature track.”

I even created a new pattern in that window “add new pattern” within my current 4/4 signature but it did not change my current pattern.
The strange thing is, if I extend the Metronome toolbar on my transport bar to reveal the current pattern, I can click on that to bring an edit window and change it from there successfully! :thinking:

Presumably I’ve got another bug in my settings? :worried:

Hi,

It works for me here. When I change the pattern in the Time Signature marker, then it is changed until the next Time Signature marker.

The Metronome Setup > Click Patterns window is just place where do you create the patterns, not where do you apply them to the project.

Ahhhh, now I get it! Thank you Martin!
I read through page 252+3 of the manual and was doing everything it advised using the pattern settings, assuming that it was the correct way to effect those into the project. I had never used the signature track so I had never seen it show the pattern next to the time signature!
I usually search and watch all the youtube channels for help so I should have found Greg’s https://youtu.be/EfYVANsX-WA but must have forgotten on this occasion!
Sorry for my ignorance and thank you for pointing this out. Maybe I’m not the first to make this error, in case I’m not the last hopefully this thread will help others. I’m want to record some Jazz Funk so I’m going to really get into the time changes on the signature track now :slight_smile:
Thanks again.