Metronome sound even turned off


I found that in Dorico 4.1.0 when I change the sound from click to Wood Block,
(command shift P)
the metronome makes a sound even if it’s turned Off.
CleanShot 2022-07-14 at 06.49.52

To fix it I need to click on the metronome icon twice.

Does the same also happen in Dorico 4.2 with you?
4.2 just came out yesterday and is a free update.
I’ve just tried in 4.2 and it works as expected with me.