When are you planning to get the metronome to work with click sounds?

Send the metronone click as a midi note to a drum VST sidehit (or a sampler triggering any click sound you like) if it’s that important to you.

Go to Transport/Metronome Setup and select the Sounds option. This will allow you to assign any audio file you like to the two different metronome ticks.

And don’t use 32bit float files :slight_smile: nearly took my head off.

I use the metronome often in CP8 and I never had a problem. Is there a condition when it doesn’t work and is it related to specific hardware being used?

The above fixes don’t always work. It’s really becoming EXTREMELY annoying. I’m ready for the fix. Something as vital as the metronome should have never been overlooked.

What specifically are you seeing (hearing?) that is wrong with it? For me it’s working the same as it always has. In what way is it broken for you?

When you turn on the pre count metronome and hit record you don’t hear the pre count. Then the metronome will not play at all and a few measure it pops back on. This is a acknowledged bug from Steinberg that MANY of us our seeing.

Got it. I never use pre-count so I hadn’t seen this behavior. Thanks.

Just upgraded today from 6.5 to 8pro and I have no working metronome (using audio beeps as I always have). I spent a while trying to figure out what I was missing. Came here and saw all of the posts about it. Really can’t believe the metronome has issues! argh. and fwiw I do have pre count on, I’ll have to try it without it. I guess I’ll have to try to use your own sounds option or just record a bar of sideclick and set it to musical mode, cut and paste it for now.

Yeah I can understand it being highly irritating (I never use Pre Count) if you use it. I generally just load up a Virtual Drum kit into an Instrument channel and draw a Kick Drum (or whatever kit piece I want) on each beat of a bar and copy that bar as many times as necessary. This way, whenever I change the BPM of the Project they will all time stretch accordingly and let’s face it, playing to a Kick Drum is far better than playing along to the irritating high Pitch Beeps of Cubase’s Metronome! :wink:

Thanks Jono, great suggestion. i didnt mind the beep, I’ve gotten used to it after all these years. I can’t get my metronome to make any sound at all. I hope they fix this asap with that new update coming

I have to route mine via MIDI to a VST as the native click doesn’t work. And I have a Steinberg audio interface! - Shows how well they tested it! :laughing:

This is a bit of a tangential to the original post.

The metronome in Cubase seems kind of “dinky” and unstable. I’m new to the forum, but see lots of posts regarding Metronome issues.

Perhaps I should post this in feature requests.

Count In Only Function not present. In my previous DAW and Sequencer (old version of Sonar, Voyetra Seq+), the Metronome could be set to “off” for both Play and Record, but it would still perform a pre-count only. The Cubase Metronome, if set to “off” for record and playback, will not sound for the count-in only, which is very disappointing to me and what I really expected to be present in a Pro level product. Am I missing a setting? Also, Is there a VSTi metronome “tool” anyone knows of which works with Cubase? I’d like a flexible metronome that sent out recordable, assignable MIDI data output with various accent settings and even polyrhythmic settings (two, three voices, tuplets with accents, almost like a mini beat designer but with professional count-in, count-down functions.

Anyway, In four, three…

A little off topic but at the same time related to the metronome:

I use the midi click connected to a VST instrument, but every time I open the project I have to reassign the midi click to the vst instrument.

Is there a way to make it permanent? Is that a bug?

Thank you


…a bug, sad to say.

And not a new one. Version 6 was the same. I seem to recall I found some workarounds but in the end it’s as easy to reload the instrument each time but it is annoying.


I’ve not tried this, but I think you could create a track with the VST-I in place and then save the Metronome track as a track pre-set to be placed in new projects.

Just reported as an ISSUE in the Cubase 8 issues forum…


hey Stephen,
I’m not sure I understood the point of your solution…

I use a big template with the metronome already loaded as an instrument, it’s annoying that every time I re-open my project/template I have to re-assign the output of the midi click to the click vst instrument…

I believe that saving the track as a track preset doesn’t solve this problem…

Am I misunderstanding something?

Thank you



Daniele, I don’t understand why your Template Tracks would not save the Instrument and MIDI assignments you’ve placed in your Template Project. Seems off, but without seeing the template I can’t say what the issue may be. I’ll keep working on it and post if I find something helpful. Clearly, the Metronome isn’t working properly for a lot of users.

My own learning curve is still crashing into identification of bugs or quirks in Cubase, but, I don’t think you’ve got anything out of place. Naturally, we’d have to see the actual template and settings to work out what might be going wrong with the template itself… It sounds like you’ve got things correctly set to me and it may be just issues with the Metronome itself. I’m sorry I don’t have anything more useful to offer at this point.