MG12XU recording with Elements 7 help

Does anyone know of a source of documentation that explains (in detail) how to record and playback using the Yamaha MG12XU mixer with Elements7? I have a number of issues such as:
a) Metronome Clicks that are recorded into my guitar track
b) poor SNR on playback even though all indicators (PFL on mixer ) and (level meter in Elements 7 ) show healthy, near 0dB levels…also the signals sound loud in the headphone monitor during record.

I have tried to follow the documentation … turn PFL’s off when recording, keep latency low (near 5ms), tried with the yellow speaker monitor button off/on during recording, but my issues are unresolved.

There is limited online info available… mostly Yamaha Commercial Material… It’s as if I am the only one who bought one of these mixers.

Thanks for any help.

It isn’t real clear how you have it set up. Are you using the USB out of the mixer to record the guitar? Is the click something you are feeding the mixer? Or, are you using the Cubase metronom?

Here are the general instructions for using the USB interface.

USB Block (XU Models Only)
• [USB 2.0] jack
Connects to a computer via a USB cable. The signal from the
STEREO L/R buses is output to the computer. (This signal is
not affected by the [STEREO] master fader.) A USB driver
might be required for computer input/output. You can download
the driver from the following Yamaha website, and
install it on your computer.
When the [ST] switch of a channel which has a [LINE /
USB ] switch is on while DAW software is being used, a
loop is formed and feedback or howling may result.
[USB 2.0] Connection Precautions
Be sure to observe the following points when connecting to a
computer’s [USB 2.0] interface. Failure to observe these rules
can result in computer freezes/hang-ups and possibly data
loss or corruption. If the mixer or computer does hang up,
restart the application and/or computer and turn the power to
the mixer off and then on again.
• Use an A/B type USB cable. The cable should be no
more than 1.5 meters long. A USB 3.0 cable cannot be
• Be sure to wake the computer from sleep/suspended/
standby mode before making a connection to the computer’s
[USB 2.0] connector.
• Connect the mixer to the computer before turning the
mixer power on.
• Always perform the following two operations before turning
the mixer’s power on or off, or connecting or disconnecting
the USB cable.

  • Exit all applications.
  • Confirm that no data is being sent from the mixer.
    • Allow at least six (6) seconds between turning the mixer
    on or off, and plugging or unplugging the USB cable.
    USB Audio
    only MG20XU/MG16XU/MG12XU
     Attenuator Function
    The [PROGRAM] knob e (page 22) can be used to adjust the
    volume of audio playback from a computer.
  1. Press the [PROGRAM] knob five times consecutively to display
    the attenuation value (dB).
  2. Turn the [PROGRAM] knob to set it between -24 dB to 0
    dB. (The minus sign is not displayed.)
  3. Press the [PROGRAM] knob again to exit the setting.
    When the attenuator is enabled, the dot lights at the lower right
    of the display.

Thanks for responding JMC

I connect the guitar directly to the channel1 mic input of the mixer.
I select the mixers USB switch which sends the Stereo Master Output to the computer.

In Elements 7 settings I have:
Devices ==> VST Connections ==> Outputs ==> Click , where I enable “click” on the Stereo Output bus

I play the guitar while monitoring thru the Headphone monitor on the mixer during recording. I hear the guitar and the click thru the headphones which is what I expected to hear. BUT when I play the recorded track back, I still hear the click track. I have turned off the “click” settings but still hear the click on playback… it is as if the click was recorded directly into the guitar track.

I am out of ideas as to what to try next… I wonder if it is a bug but surely someone else would have had the same problem


You have created a loop back. Please search for that on the manual.

Good call JMC

I use the red 'ST" button to connect the mixer’s USB Channel to the Computer which is warned about in the MG12XU mixer manual stating that this will cause a loop and feedback or howling will result. The problem is that there does not appear to be any other way to hear a metronome or over dub a new recording while playing back from the DAW without using this ‘ST’ button. They should call it the Loop/Feedback Howling Button to be more precise.

I am hoping my in-experience is what is causing these issues… if it turns out that there is no work-around for this, I will have to conclude that Yamaha hardware is bottom end.

That doesn’t sound correct … there should be a way to send a stereo out and monitor from the stereo return. What I think was happening is that you were both monitoring from the mixer and from the return from Cubase … and just an FYI, there are situations where that is desirable. I don’t know jack about that mixer, but I’d be surprised if there weren’t a way to do what you are trying to do, which is to feed the audio to Cubase, but only hear the return from Cubase.

It is a low end device however … $300 for a 12 track mixer with an audio interface is pretty much rock bottom. But, I’m thinking there is a way to do what you want. I could be wrong though.

Just got my MG12XU connected to Cubase.
First impression is rather mixed.
Besides strange glitches related to USB adapter I have difficulties to record and monitor at the same time.

USB issue:
mixer has to be switched on only when Windows is fully up and running, otherwise adapter is not recognized and mixer starts behaving funky – e.g. some LEDs indicators stop working properly.
Did you experience this behavior?

Recording issue:
I have to disconnect playback from the stereo channel – meaning – no playback sound from the computer / Cubase possible using monitors. I still have a possibility to connect Headsets and listen it there via Group 1-2, but in case I want to record synth or guitar – no way to record and listen it via monitors at the same time.
It is because the USB takes signal for the recording from stereo bus and sends it to the computer and this is the only bus can be used for listening via main monitors/speakers.
Do I miss something?

I also am struggling with the MG12XU mixer.

USB Issue
I have the same situation but at least the driver loads and a connection is established

Recording issue
I am stumped as to How to Overdub. I simply wish to record a guitar track into the Cubase DAW via the mixer and then, Play the guitar track back from Cubase DAW and while listening (Somehow) to the guitar track, I would also record simultaneously a Vocal track into the Cubase Daw.
Seems pretty basic and fundamentally a very important capability.

I have (so far) been able to accomplish this in a poor manner by selecting the USB/Line Channel with the “ST” button selected BUT this creates a “Loopback” situation where you get feedback/howling noises if the “Sliders” are set too high. BUT I believe this is not a robust way to Overdub.

Your point about the stereo bus being the only bus that is used for listening is interesting

It is because the USB takes signal for the recording from stereo bus and sends it to the computer and this is the only bus can be used for listening via main monitors/speakers.

There is an “Input Stereo Bus” and an " Output Stereo Bus" associated with the MG12XU. Is there some way to set additional busses in Cubase to pull this Overdub miracle off … something like Output Stereo Bus1 and Output Stereo Bus2 for example?

I feel my story is missing some further details, “stereo bus” is the one in the mixer itself.
And this is exactly where I got a bit stuck.
When I listen Cubase playback (Cubase Steres out -> USB) - it goes into the mixer, then via channels 11-12 it goes into the internal mixer “Stereo bus” or/and “Group 1-2”; or “PF” (pre-fader Listen) intenral buses.

If I read the MG12UX block diagrem correct, to get the sound into the monitors connected to main “Stereo out” the signal has to be routed to mixer internal “Stereo Bus”, and it is exactly the only line used by mixer USB controller to get sound to the Cubase.

The only way I have found: to get Cubase playback sound and record at the same time without Overdub to route playback signal from Cubase -> USB -> Channel 11-12 via “Group 1-2” or directly from “PF” (pre-fader Listen) to “Monitor Out” (no internal mixer “Stereo bus” used in this case); and use internal “Stereo bus” to channel the sound into the Computer only.
This separates routing on the mixer “Group 1-2” for Cubase play back and “Stereo Bus” - for the recording to the Cubase.
To me this looks to be weird approach bringing me to the thoughts about returning the device back before it is too late.

I do not see any solution on Cubase side as the sound is mixed inside the mixer and has to be split there.

Did you try this approach already? You can use heads sets – this should be possible as well.

I also have tried using Group1,2 for Playback and Stereo Bus for Recording. This will allow you to playback and record at the same time.


To hear the playback thru headphones, both Ch11,12(USB slider) and Group1,2 slider must be raised.
The problem with this is that as the Ch11,12 slider is raised , the recorded channel begins to have an echo sound in the headphones. The higher the Ch11,12 slider setting, the larger the echo. I guess this is the “Latency” that is always talked about. The Cubase performance meter says the Latency is only 6milliseconds but it seams worse than that.

I too am coming to the conclusion that this MG12XU Yamaha Mixer is a poor compromise for an Audio Interface.

One Question:
What should I be looking for in my next piece of Audio Interface Hardware that will give me confidence that this hardware will perform the Overdubbing/Multi-tracking in a professional manner?

thanks you for your correspondences… they have been very helpful

Is it possible to record using more than 2 channels with this AI
for eg

4 mics, each on individual instruments recording “simultaneously”?
any help would be nice
:question: :neutral_face:

Hey, so I’ve had this same problem trying to record with the Yamaha MG 10 XU on Cubase software, and for some reason it will only let me set the audio output back through the mixer, rather than me being able to send it out through my computer’s head phones. Which creates that looping problem.

I’ve tried for a bit to fix it so I could use the program, but so far the best solution I’ve found is recording on Audacity (which actually is able to send it to my headphones and not to the mixer) and then just editing the files on a better editing program after.

The “some reason” for that is, that Cubase can only use one ASIO driver at a time. Google for “ASIO4all”, or “Aggregate device”, (depending on used platform). And the looping problem is not created by that, but by you not having the mixer routing configured correctly.


I know its an old thread but has anyone figured out how to do over dubbing with this mixer without feedback loops ? I just got the mixer and Im stumped. Using Cubase LE AI 8.5.

What are the button setups to hear a track from Cubase and a click track and record another without recording the click and without the feedback ?


I am using Cubase 8 Pro. As stated in the Yamaha owner’s manual, page 10, items 3 and 4, you need to have the On and ST switches set on the channel you are recording through. So, if I have a mic plugged into channel 1, I only set the switches for that channel.

I have a USB cable running from my PC to the Yamaha. To hear output from my PC, on Channel 11/12, I set the Line/USB button to USB. I also must set the PFL button for 11/12. I am using a headset so maybe that’s why I’m not hearing a ‘howl.’ I have no problem hearing the Cubase metronome as I lay down multiple tracks.