Midi - Audio record

I’ve been having problems with audio recording for some time now!
When recording audio, the Nidi tracks are recorded, I have already changed the settings in audio connections, always the same, even when I play the MIDI keyboard, it shows data input in the audio track.
I don’t know where to look for a setting for this data reversal.
I would be grateful for information about the problem.


Where are your MIDI routed to? Do you use virtual instruments?

Please, double-check if the Audio Loop is not enabled at your Audio Device (which one do you use)?