Midi CC recording bug in Dorico 5

Hi, unfortunately I´m having trouble to record midi cc data. If I delete all automations from the project and record midi cc on a selected track using my breath controller (Tecontrol BBC2), I can do this once without issues. Once Midi CC Data is present in the file and I choose to record more parts Dorico won’t record them at all.
-The green midi activity light is showing that Midi Input arrives as it should at all times → The Midi CC messages seem to get stuck somewhere after this.

  • tested on lates Dorico 5
  • Ive tested the breath controller in other DAWS and everything is working as it should…

As stated before, I’m assuming it is a bug. Should anybody have an idea what else to try , feel free to share!
Interlude_Tecontrol.dorico (1.4 MB)

Welcome to the forum, @Sanseb. I’m sorry you’re having this problem.

I only have a very simple MIDI controller here (a mini keyboard with a single rotary volume control), but I’ve just tested this again for myself to make sure, and Dorico is happily recording CC 7 (channel volume) from this controller every time I use real-time recording, overwriting any existing data as I would expect.

Are you finding that Dorico will record neither notes nor MIDI CC data, or that notes are recorded but no CC data comes along?

Ive tried the on a new project creating Midi Notes and CC 1 data with my Novation SL mk2 using the Modwheel. In a vanilla project Midi Notes + CC Values are being recorded correctly (even though no audio can be heard when recording). When overwriting the recording (is also true for using the undo function and then record again) no notes or messages are being recorded…

I have encountered this quite frequently with the same breath controller. What worked for me was trying to ensure that the recording staff remains properly selected - for example clicking the same location on the staff twice or trying to click it right after starting the recording.

I think the issue is Dorico mistakenly switches a voice or something like that. Auditioning volume used to behave the same way - needed more than one click to sound at correct volume. Even now, it sometimes takes clicking twice or more on a staff to make it active and switch auditioning to it

Is there a way to delete the Midi Preferences File from the library Folder and rebuild it?

Currently, Dorico won’t trigger any notes when pressing a key on my input devices, even though the green Midi button is lighting up as it should.

I deleted everything Dorico related from the library and installed everything again. So far it seems, this was causing my issued. Everything seems to be working as expected.

Thanks to everybody who helped and participated!

EDIT: I was too quick to call it a day. Turns out all Midi signals are being transmitted. In a live recording, the first few bars will be fine. After Bar 10 or so, arriving midi data will no longer be processed and displayed by Dorico.

To me that sounds like a buffer overflow somewhere in the midi chain…

I don’t think in general Dorico has a problem with handling real-time MIDI data. Can you run a MIDI monitor on your system and see what MIDI is actually being generated by your breath controller?

Here is a 5 sec sample of the data being generated by the breath controller when using it… (created with Midi Monitor)

Breath Controller midi CC Data.zip (86.0 KB)

Thanks – this data looks fine. Dorico should even be recording the breath control data as MIDI CC 2, if you look in the Key Editor.

I´ve been doing some more testing and here is what I’ve found:

-Recording Midi CC Data in a clean Project not containing any Midi CC Data works fine.
-overdubbing Midi CC data causes a conflict (sound flickering) as Dorico is trying to playback the containing Midi cc Data swell as the overdub input data.
-From this point on stuff gets messy:
Deleting all automation and rerecording will not help → From this point either no more midi data is being recorded at all // sometimes it will record a fraction of the performance.
-Starting a new project will resolve the issues. Until the first recording - whereafter I find myself back at square one of this cycle…

(all unnecessary Midi Devices are unchecked in Dorico).

I really can’t explain why this isn’t working. Even if you use Play > Automation > Delete All Automation so that all existing MIDI CC data is removed, you’re still unable to record more data in the same project?

Ive deleted all automation before in the way you suggested. Doing so takes me to the “From this point stuff gets messy” section of my last post…