Midi CC sending out multiple ports?

I’m having a strange issue that I cant seem to figure out. I’m running an IAC midi bus (mac) which is suppose to function just like a hardware midi bus - so PC people please read on as you may still be able to help. :slight_smile:

I have a setup this IAC Driver in Midi Port Setup, just like you would a midi interface. Its set to only be an Output, as I’m only using it to trigger sounds from a standalone synth. I then created a midi track, set the midi out to this IAC Driver, and voila - I’m triggering the synth fine! WOO HOO!

However, I noticed that when I use midi CC on different tracks, its effecting this IAC Synth, but its just midi CC - notes are not triggering it. So for example if I load a retrologue directly in Cubase, and mess with its pitch bend, it causes this IAC synths pitch to also bend! This only happens while playing / recording - actual playback does not get sent to the IAC synth.

So I’m at a loss as to whats going on. It seems midi CC’s (not notes) are being sent out this IAC bus from every track in Cubase, but only while in record mode and not during playback. Any advice would be greatly appreciated as I’m stumped!

Can you give us a more precise description, please?
You have one MIDI track routed directly to Retrologue (or Retrologue as an Instrument track, doesn’t matter :wink: )?
You have a 2nd MIDI track routed to IAC Bus 1 (on MIDI channel #1?), and your standalone instrument receiving from IAC Bus 1?
Both tracks have your external keyboard as their MIDI input? (There could be MIDI feedback problems if you have this set to “All MIDI Inputs”)
Which track is record-enabled when you are experiencing this problem?
Do you have MIDI Parts already recorded on these tracks?

Sorry for lack of clarity.

I have 1 midi track routed directly to Retrologue (indeed its an instrument track :wink: )

I have a 2nd midi track routed to output IAC Bus 1 on midi channel 1 and my standalone instrument (Mainstage) is receiving from IAC Bus 1, midi channel 1.

When I recorded I had both tracks set to “all” as midi input (note IAC bus is NOT set as an input in my midi setup, only as an output). Thinking this might be something I just now set the IAC track’s input to “not connected” - still receives midi CC though when playing on the retrologue track.

The Retrologue track is set to record enable when I have the problem - IAC track is not set to record or monitor midi.

I do have midi parts already recorded on these tracks, and when I play them back they are indeed seperated and play back correctly (i.e. if recorded pitch bend on retrologue, it only plays back on retrologue). However when I RECORDED the part, pitch bend was sent to both synths, which made it very weird to record. This is especially true when I use volume automation while recording, etc.

I guess this is still something I can work through for now, as it only happens when recording and playback is fine, and if needed I can always record the mainstage instrument as audio so its locked. I’m just curious as to why its happening. I also wonder if it could be something in Mainstage causing the issue, but I find it very weird that Notes are behaving correctly (can play notes on the retrologue synth and it does not play the IAC synth) but any MIDI CC I do (pitch bend, modulation, etc) are effecting both tracks!

You know, I think something has stirred my memory…
Unless I am mistaken, you can’t actually select an input to Mainstage… it always reads whatever MIDI input is arriving at the Mac (so it is receiving not only from the IAC bus, but also from your keyboard directly)
You can verify this (or otherwise :wink: ) by running Mainstage without Cubase even being launched.

I have it setup so that the “keyboard” (which is how mainstage is setup - each keyboard is basically a track with an instrument on it) is set to receive only IAC bus channel 1.

As a test I created a “concert” with two keyboards, one set to the receive my midi controller’s channel 1, and one on channel 2. I then proceeded to play the keyboard on channel 1, and when I used my expression pedal it did not move anything on Channel 2. However, if I switch this setup back to IAC bus (keyboard one on IAC midi 1, Keyboard 2 on IAC midi 2) and then move my expression pedal - I can see BOTH instruments reacting to the controller! If I play the keys, nothing is happening, but when I move the expression pedal I see it move in Mainstage.

I dont know what to make of this information, but yeah, it doesn’t seem like a Cubase problem. :frowning:

Thanks again for your help Vic_france! I very much appreciate it!

To me, It sounds like Mainstage is receiving your keyboard input as well (or something of the like). Have you tried this same setup in Logic instead? Maybe having the Environment will make things more customizable so you can bypass your keyboard midi ports and stuff if needed. I remember when I did this same setup I needed the Environment to get rid of the midi loop IAC causes. Though, it’s been a long time since I did this setup so my memory could be hazy.

-WHP Enterprises

(I’ve had to do a bit of a quick learning curve! :stuck_out_tongue: )…
I think I got something for you :wink:
First of all, i was off the mark when I said we couldn’t assign specific ports as MIDI input (which you had already discovered anyways :blush: :slight_smile:
I think you can sort out this problem in exactly the same way as you selected the IAC Bus as keyboard input (Switch to the Layout pane in Mainstage, click on the keyboard and change the settings in the left panel).
Well… it is true to its word… it changes the keyboard (but nothing else!)… you have to do the same for every other controller that is visible there… you have to actually click on the pitchbend wheel, modwheel, expression pedal, sustain pedal etc… and do the same for those! (just tried it, and it works :wink: )

TIP (but maybe you’ve done this already :wink: )…
Do you have Soundflower installed? Add it to an Apple Aggregate Device, together with your “regular” audio interface, and use this Aggregate Device as your VST Audio System, and as your audio device for Mainstage. You can now, not only send MIDI into Mainstage from Cubase, but also route Mainstage’s audio back into Cubase :wink:.

BTW, ain’t it fantastic that Alchemy is now included in Mainstage 3.2? :slight_smile:

Thank you both for the help! I’m going to try this tonight. Getting Alchemy for free in the latest update has given me all the more reason to try it! :slight_smile:

It works!! Thank you very VERY MUCH!!

Well I found an issue. It occurs when playing multiple instruments from Mainstage - which takes a bit of work. Here is what you do.


  1. Go to mainstage. Click the “layout” button and create two keyboards (to create the additional keyboard you have to go to “shelf controls” and double click they keyboard icon.

  2. Click on one of them and set it to MIDI PORT IAC & Channel 1; click on the 2nd and make it IAC Port & Channel 2. Name them key1 & key2 (under settings while assigning ports)

  3. Add foot pedals (from shelf controls again) and assign them to expression (midi CC 11) making sure one is on IAC channel 1 and one is on IAC channel 2.

  4. Go into the edit page and click the cog in the patch list (upper left of the interface) and choose "new patch with channel strip. Name the first Organ 1 and set midi input to key1. On the bottom under “channel strip library” choose vintage B3 folder and load a preset (mine was called bebop organ)

  5. Click on the cog in the “channel strips” window (NOT the patch list) and choose instrument channel strip. Choose another organ (I choose Classic Rock Organ). While it is still selected go to the bottom of the interface named “Instrument Channel Strip Inspector” click on the tab “midi input” and choose key2 as the input.

  6. Now open cubase and create two midi tracks, one assigned to IAC midi 1 and another assigned to IAC midi 2. Arm midi 1.

  7. Go back into mainstage and open both organ instruments by clicking on the channel names “Vintage B3”

  8. Play your keyboard and you will see the lights light up for one of the two organs (the one on midi 1). now go to the options tab on both organs, and run your midi CC 11 fader.

For me, I see BOTH organs “expression” wheel move! Anyone have a solution for this or an idea of what I’m doing wrong?

I had been experimenting with similar, also :wink:.
Do you get the same problem if you send to the 2nd organ (on ch.2)?
I get the impression that Mainstage isn’t %100 bugfree.
First thing I would do is take a look at the assignments for your expression pedals. Check they haven’t changed.
If you have the time (and the inclination :wink: ), try to set it all up again from scratch, but create only the first organ (on ch.1). Send to Mainstage on IAC Bus, ch.2 (it might already be showing the problem).
It really doesn’t help that Mainstage’s parameters are scattered just about everywhere! :wink:.