MIDI chanel issue with M-AUDIO CODE

Hello everyone,

I just got my new MIDI keyboard M-AUDIO CODE 49 so I tried to use it with my Cubase Artist 9. I followed all the instructions how to configure this device with Cubase from the official website of M-Audio: http://m-audio.com/kb/article/1902
My first impression was that everything was gone well, my keyboard sent signals to the DAW. But then I realized, that no matter which midi channel I choose on my virtual instrument in Cubase it always plays. For example, if I set up 4 different midi instruments on 4 different tracks with different MIDI channels, the input is set on CODE 49 and I turn on the “monitor” button on each track, all 4 instruments play simultaneously during I play my MIDI device. And no matter what global channel I use on the MIDI device, it always plays all 4 instruments. The same problem occurs when I split my keyboard into 4 zones, each with separate MIDI channel - no matter which zone I currently play, all active instruments on different channels play as well at the same time. I couldn’t find any solution and I know, that the keyboard is ok, because I tried it on a different DAW - Ableton Lite which came with the M-AUDIO CODE 49. Does someone have an idea what I am doing wrong? I can’t imagine that is was an issue in Cubase.

Thanks for your help.
Best
Ricc

Hi once again

Topic closed - I found a solution - you have to set up a input midi channel in cubase in the input transformer - see here a good article: http://m635j520.blogspot.ch/2013/01/midi-channels-in-cubase-or-there-and.html

Regards
Ricc