MIDI channel separation issues

I have bought a Arturia Kelab Essential 61 MIDI controller to use with my Cubase Elements 12. The Keylab has a separate app called Midi Control Centre for programming it. I can’t seem to separate the sounds from the pad from the sounds from the instrument, even when I allocate them to separate channels.

For example, when I have a sample assigned to note C0, triggered by Pad 1 on channel 10 and an instrument loaded on channel 1, the instrument still sounds when I hit the pad.

Any thoughts?

Cubase has a very poor method of MIDI channel management unfortunately.

What you need to do is go into the “Inspector” of a track that you want on a specific MIDI channel and open the “Input Transformer”, then select “track”. Then open the panel and select the factory preset “Channel 1 only” (or whatever channel you want on that track) from the channel filters.
Make sure that the preset is checked as “on”.

If you make a channel filter for channel 10 on the track you want to receive your pads, this should do it.


You have to set the midi channel on the track to “Any”. This allows the channels which are setup in the keyboard itself to be used by Cubase for this.

When the track’s channel is set to 1 through 16, the track 's output will be sent on that selected channel, regardless of the channels sent by the keyboard. You need it set to Any in order to do what you want, which is send to different instruments based on channel.

Right. Not.

Bull. It’s a completely dopey system. The channel filtering itself is done with an arcane method of many-click submenus and the most intuitive place to put the channel assignment is right in the inspector where it should have been from day 1.

Cubendo didn’t even add its factory presets for channel filtering until recently (v12 I think?). Before that you had to program your own.

It is completely unintuitive that you have to go through all that trouble to receive incoming MIDI from different channels. It is not something to dig for. Its basic MIDI 101. The current method is a huge bottleneck for setting up large templates. Any basic feature that wastes that much time to implement needs a rethink.


rant on, I guess.

BTW, your suggestion does not fulfill what the OP asked for.
He is trying to separate the MIDI channels to different tracks, not send all MIDI channels to all channels, which is what your instructions do.

Since Elements doesn’t have the input transformer, it’s not in play for this question. I answered with the presumption that @RalphNT is using a multitimbral instrument.

In what way do you assing a sample to a MIDI controller? You must be using some part of Cubase for it. Please give us the details. Also the details in which way you “load an instrument” on channel 1. Are you using plugins in Cubase for this? Which ones?

Your suggestion is based on a feature that the OP does not have with Cubase Elements. Please don’t be so aggressive to others when clearly nobody is free of mistakes.

I suggest we find out some more details about OPs setup and intention. Maybe we can find a suitable way to help him.

Looking through the Elements manual, I think you are right. It doesn’t look like it has the Track Input Transformer, which means OP is totally out of luck. There is no way to do what he is asking to do without being able to filter by MIDI channel.

@Johnny_Moneto I’m dropping the sample onto an empty pad in Groove Agent and assigning the trigger note accordingly. Groove Agent is on channel 10 and I’m using Halion Sonic SE on channel 1.
@steve Setting the track to ‘any’ seems to have done the trick - thanks. As long as I have the monitor buttons enabled.
@VV1 Blimey, calm down.
Who’s ‘OP’?
Thanks to the wonderful Steinberg community!

1 Like

Glad that sorted it for you.

“Original Post(er)”