MIDI channels still present on the Mackie MCU after hiding them in the MixConsole

I just upgraded to C11 from C5 and am getting used to it quickly. I have a Mackie MCU and when I hid the MIDI channels in C5 the faders disappeared on the MCU as well. I hid the MIDI channels in C11 on the MixConsole but the faders on the MCU do not disappear. I have read the user manual on how to hide them on the MCU holding the SHIFT key and pressing the associated number but nothing happened. Thanks in advance for any help/info.


I figured it out on my own…

If anyone is wondering I was able to open the MixConsole panel from the drop down menu
When the window opens up you will see the [visibility] panel to the left side of it. As you uncheck each MIDI channel you will see them disappear from the MCU controller. Not sure if this will work with any other controller (I assume it will).

1 Like

Something to be aware of is that mixconsole 1 is what the MCU syncs with. You can use mixer 2 and 3 if you want differing views on your computer vs MCU.


Yes, I can confirm this. MCU and all Remote Devices are synced with MixConsole 1.

Moreover, MixConsole in the Lower Zone is not synced with MixConsole 1.

“all remote devices are synced with MixConsole 1” is imho not true for Eucon-Controllers. Or is it?
I mean, with EUCON Controllers you can Control MixConsole 1, 2, 3 - simply depending of what is in focus.


The faders of all MixConsoles are moving, of course. I mean “in-sync” in sense of the visibility.