MIDI - CLOCK ~ Issues

Hello guys,

I would like to share my recent problem with Cubase 8.5.20.169 / 32bit (on Windows 10 64bit System, 16gb ram)

I am dealing a problem with Midi & Midi Clock thru my Modular System.
In the modular i have Mutable Instruments “Yarns” module for the midi input.
In my desktop i have Motu Midi Express 128 and a Midi Uno USB 2 Midi, interface.

Setting Cubase to send midi clock to all my Midi Devices,
and sending a simple midi gate of 1/16 to the modular system.

Recording from modular without any other modulation from a simply OSC that receives the signal from “Yarns” thru (Motu Midi Express or Uno USB 2 Midi Interface).

The result is to having some “swing” to the gates. (or before or after the “bar” that suppose to be)

I tried also various interfaces to send the midi notes and clock (like Virus Snow Midi-Out, Roland System1 Midi Out),
but i am dealing the same results.

**RME Fireface 800 - Buffer 64 to 256 Samples, makes no difference.
**New Empty project with nothing on it, makes no difference.
**The Modular system stand alone clocked & with a sequencer, works without any problems (all modules checked one by one).

The only solution I have found for the clock is to send a straight audio signal (pulse waveform), and having a super accurate result.

But when it comes to play with notes there is a big mess.

I have from Devices try, with and without enabled the two timestamp options of the midi properties, no luck also.

I had this issue before some years with Virus C, but Virus Snow thru USB is working perfectly.

I would like to know if there is anyone who had experience the same issue, and if there is some suggestions to make this work.

Thank you in advance.

My system :
Intel Core i7 4770K 3.50Ghz (Haswell) (22nm) / 12MB Cache
(Core Voltage : 1.390 / 4600MHz)

LGA 1150 (Socket H3) - ASUS Z87-A (Bios v2103)

Intel® HD Graphics 4600 (OnBoard) / 1024Mb
Radeon HD 4670 - 512Mb / 128bits / RV730 / 55nm
ATI AMD Radeon R5 200 Series - 2048Mb

DD3 - Kingston - 2400Mhz (16GB)

Sounds like your experiencing ‘jitter’ from the Cubase Midi Clock. Unfortunatley, I don’t think the jitter can be eliminated from the Cubase Midi Clock stream - this is the reason for the various 3rd party audio to midi clock generators like ERM Multiclock, Innerclock Syncgen, ACME-4, ExpertSleepers USAMO…

you might want to read this short thread I started on GS:

https://www.gearslutz.com/board/steinberg-cubase-nuendo/1104961-external-sync-not-syncing-very-well.html#post12053910