Midi clock out. Offset compensation

When using Cubase Midiclock OUT for starting playback of external hardware sequencers (via both USBmidi and soundcard midi) I get an audible offset of about 14ms compared to internal VSTi-drum track.

Ableton has a midi clock delay compensation in its preferences. It seems so extremely essential to be able to compensate for hardware that i am stunned that this isnt a setting possible to do in cubase. (Not that i am aware of anyways)

The only workaround i have is to delay offset every recorded track manually in its track delay setting.

Please make a Midiclock Sync Offset

(PS. Yes, I have tried settings like Direct music, timestamp, ignorefilter ports etc. It makes no difference)

This one’s been treating me well on that matter: https://www.e-rm.de/multiclock/

Bump. You shouldn’t have to buy another device to achieve this simple and very important function in your DAW. It’s really frustrating. I’m still on 6.5 (stable on my OS), just re-setting up my studio, trying to sync my Jomox and Xoxbox to cubase is a ballache. Same. 14ms delay, sounds unworkable. Play a preset beat from Arturia Spark Vintage in standalone mode, Midiclock out adjusted for latency, nice and tight. Now I want to start a proper project with that beat, can’t do it.

I have been dealing with this issue for many years and I’m happy I found a free workaround using voxengo latency delay.
I made a quick video : https://www.youtube.com/watch?v=fG90TCri0_g&t=4s
Hope that will help some people out there…

I don’t understand why there is no midi sync offset in cubase :open_mouth:

Okay same situation here exactly as described a constant 15 ms MIDI clock offset, very audible when using external gear and it messes up my workflow.
For all that is holy, please add a simple MIDI clock offset setting. This should be base functionality people. P.S. Cubase 10.5
Many thanks

second that…now its cubase11 and still no adjustable offset on midi clock/sync…this is a basic need for all people, using external hardware/synths