MIDI comes through partly but doesn't record


I’m trying to connect my Casio WK-245 to my PC, which has Cubase Elements 10 and Windows 10. I connected the USB cable and everything seemed to work. However, after trying for a few hours to get it to record, I haven’t gotten anywhere. I can choose VST instruments in the media bar on the right, and when I play the keyboard, it produces sound. The memo recorder works too. So the data seems to be getting through in some sense. But when I set up a midi or instrument track and press the record button, nothing happens. And if I don’t click into the media bar and select an instrument there, creating a midi track produces no sound - it doesn’t get through there.

I think it might be recording the sustain pedal and the on/off of the notes, but not the actual notes? I’ve tried changing the filtering settings, making sure the time is set correctly (I saw that as a suggestion on a previous question), and setting it up as a midi or as an instrument track. The channel is consistently set to 1. But nothing happens. I’m probably making some basic mistake because I’m new to this, but anyway, if anyone has any ideas I’d appreciate it. I’ve attached some screenshots

Hi and welcome,

I can’t see any incoming MIDI activity in the Transport Panel.

Could you try to switch to All MIDI Inputs? Are you sure your Casio transmit the MIDI data to USB? For some hardware, you have to set it up, if you want to send the MIDI data out via MIDI 5-din, USB or both.

If you create a MIDI track, you have to set the MIDI Out to some synthesiser.

Your MIDI channel 1 is being filtered…

Oh, right! This button is so invisible. You can’t really see the state for the very 1st look.


I had similar issue - very hard to see

Thanks! It works now. I didn’t even notice that that was selected.