MIDI connection problems with Studiologic Numa X Piano in VST Live

Hi folks,
I currently have a connection problem when using a Studiologic Numa X Piano and an Akai MPK 261 in VST Live Pro on a MacBook Pro M1. When I connect the Studio X Piano and assign it to MIDI IN 1 in VST Live there is no midi signal in VST Live. I have tried several different procedures. Switch on the keyboard before opening VST Live, switch on the keyboard last, restart VST Live. Unfortunately, none of the variants work. Only when I restart my computer while the keyboard is switched on does the MIDI signal arrive in VST Live. Otherwise, the keyboard is recognized and displayed, but no signal is received. Have other users encountered this problem and is there a way to solve it?
In addition, it generally does not work for me when I assign MIDI IN 1 in the start screen. I still have to assign the MIDI INs again under “Devices → Connections…”.
I’m currently using Version 1.4.50.868 (x86_64).

Thank you very much for your help and best regards

Hi! First, in my experience, ports needs to be present at opening VST Live.
Second, give try to the last pre-release, pinned to this forum on friday evening (it will be a direct download instead of SDA).

Let’s collect further ideas after testing again :slight_smile:

@chris.rudolph, yes, that’s a good suggestion from @fkalmus. Have you installed the latest Pre-Release? Is it better? I guess you want run play a Layer with an instrument? What about TRACKS? Have you tried this one?

  1. Start VL
  2. Select TRACKS
  3. Add MIDI Track
  4. Select MIDI Input in the Inspector
  5. Select an Instrument with the Output
  6. Enable Monitor Button (orange one)

Does this work?
Michael.

1 Like

Are you using USB for the MIDI connection? Could be a driver issue. If so I would suggest using 5 pin cables or wireless MIDI. I have an SL88 Studio - works great on CME WIDI…

Thank you very much for your support. I didn’t think it would be so easy to solve after all. The last pre-release was a great tip and since I installed it, it works without any problems via USB!