Midi Controller Mapping done after every project despite saving them and importing the settings file.

Hi! Everyone

I use M Audio Code 49 Midi controller/keyboard and Cubase 10.0.20.

For every project, the mapped settings are not remembered by Cubase 10. Even when I imported the settings file that I last saved, it does not work.

This happens even if I see that the settings are there as I last saved them.

Can someone advise what I can do to avoid this?


What kind of settings exactly do you mean, please? Do you mean Generic Remote Device?


if you are using Generic Remote to map the commands, you need to save (export) the settings into an XML-file. Upon restart of Cubase or opening another project, the settings are back.

Don’t know, how and wheather this works for other kinds of remote controls to.



Right, you have to Export it, not Save. But as far as I know, this is Mac bug only. Or am I wrong?

I’m having the same issue on the PC. I couldn’t figure out why. I thought the problem was with my Roland FA08. When I opened a new project I found the transport controls on the FA08 didn’t work. They don’t work for my older project either ( everything used to).
If I get all dialed in again how do I save it?


Use the Export button in the Generic Remote window.

Hi! Lg

It is strange that I never received notification for responses from you guys.

Firstly thank you for taking time to respond.

Even with recent update, the exported xml files could not be recognised. This means that Cubase 10.5 does not recognize the file.

Hi! Martin,

Thank you for responding.

I used it before upgrading to 10.5 and 10.5 did not recognise the XML file.


This bug had been fixed in Cubase 10.5 and it’s not necessary to click the Export button anymore.


What exactly do you mean it’s not recognised? When? Can you select it in the load dialog and then nothing happens? Or you cannot select it in the load dialog at all?

after importing it you might need to press ‘Apply’ in the bottom right corner of the Generic Remote Device setup.


This shouldn’t be the case since Cubase 10.5. Actually since Cubase 10.5 the Apply button doesn’t make sense.


I simply mean that the widow of importing does not select the xml file. It gives off a message as it’s not a recognised file.


I have just tried this on both Mac and Windows. It works to me here on both platforms.

On Windows, you can choose if you want to show Generic Remote (.xml) files only or All Type (.*) in the Import Generic Remote dialog. Have you tried both options, please?