Midi controller not triggering Halion SE3

I have tried everything…!

My LPK25 will not trigger Halion.

So frustrated…!


Hi and welcome to the forum,

Could you attach some screenshots from the settings, you checked, please?

1 Like

Thanks for quick response.

Tell me its me…

Is the LPK25 displayed in “All MIDI inputs”?

1 Like

Makes no difference.

Try activating acoustic feedback (the speaker icon) on the Halion tracks?

1 Like

Not sure what you mean. Where is “the speaker icon”

Thanks for getting back to me bud

To the right of the record arm icon.


In the track list, the Monitor button, this is the “speaker icon”.

Hopefully I’m being dumb… I still can’t find it.

Exactly which window are we talking about (noob here).

The leap from CuBase5 to 12 has been painful.

I’m using Elements 12, says only pro up top in Acoustic Feedback note on Steinberg.help (won’t let me post link!!!) It shows the icon too.

Thanks for help none the less!! X

Found it here.

Makes no difference.

Not just Halion effected.

LPK triggers nothing.

It is showing its active and triggering in the transport bar.

Going crazy now.

Please be simple!

All looks right?

Is the midi channel correct? On your screeshot the midi track sends to channel 2 but in Halion you have program loaded in slot 1 which is channel 1 by default.



This is not Acoustic Feedback. The Acoustic Feedback in the Key Editor is here to be able to monitor the MIDI Notes while editing in the editor (for example click to the MIDI Note and hear it).

This is the Acoustic Feedback icon:

If you want to hear the instrument while playing the MIDI keyboard, enable the Monitor (speaker) button of the track, or the Record Enable button. If the MIDI data has been recorded already and you play them back, disable the Monitor and the Record button, please.

Of, this is a great point! I overlooked it. This is it!

If you send the MIDI data to MIDI Channel 2, you would need to place the sound patch in slot 2. At this moment, you will see the number 2 in the HALion Sonic blinking while playing back. This is the indicator, this slot receives the MIDI data.

So the solution is to change the MIDI Channel of the MIDI Track to 1.

1 Like


To hear input going into a track you need to ‘arm’ it first.

There are two ways to ‘arm’ a track.

  1. For monitoring purposes.
  2. For recording to a track.

If you toggle the ‘monitor’ button for a track, and have a midi controller designated as the track input, then you should be able to hear whatever plugin/instrument is set at the track’s end point.

If you toggle the ‘record’ button, then it alows you to hear, but it also enables the track to record next time you punch the record button on the ‘transport’.

1 Like

Hi Guys,
To add more frustration to this problem I have been unable to respond to you as this forum only gives me limited responses in a given time frame as a new comer. I should be able to start commenting again now!

None of you suggestions work I’m afraid. I have messed around with everything including channels. Well spotted about the channel differences. Like I say I had hit a point where I was trying extreme and silly things out of frustration. I think this a bug. I don’t think this problem is isolated to just me.

Link here but won’t let me post links yet. Title of that thread is …

[Cubase 12 Elements does not work with any midi keyboard]

I’ve opened a fresh project still no go. Really starting to regret this leap to E12. It’s been crap for other reasons that I have gotten over until now…ranting. Sorry. Sad face now. Where to go from here.

Pic attached.