Midi device mayhem.......!!!!!!!!

Hi all,
Ok first off please forgive me if there is an easy fix or solution to this issue, I have tried my best to find stuff on it but nothing that helps sofar. My problem is with the midi ports that are assigned to midi devices that i create. my setup is:

external devices x 2
Roland xv-3080 on a usb to midi cable with dedicated audio inputs on mr816csx
Gem S2 workstation on usb to midi cable with dedicated audio inputs on mr816csx

I can create a midi device for the xv3080 no probs and have a script file all is good. I assign the apropriate output which i renamed in the Device setup window for midi ports. I prechecked i had the right ports to the right names etc by creating a basic midi track in an empty project window and assingning relevant midi in/out to it. I then goto connections and sort out the audio inputs for the new device. create a new instrument track using the new ext instrument i just made. All works perfectly with no issues, so i move on and go through the same process for the Gem S2. all goes well untill i need to assign an output for the device, i open the drop down menu for midi outputs and select the port i named to gem s2, … it will not select it it just picks the one for the xv, i can how ever select some of the othe midi outs for other devices such as bcf2000 which are connected and working .

I made a template for my home setup a while back and all was good no issues, all midi port names etc all correct and selectable and send midi info to correct destination. Then some how the gremlins get into my system from somewhere and every time i switch on cubase 6 my midi ports rename themselves all to the same name i.e xv-3080 or Gem s2, different each time i switch on, so its hard to keep up,…BUT the same recurring thing is that no matter what cubase changes the name to it all still goes to the xv 3080 midi output. Is there a max number of usb inputs allowed before C6 spits its dummy out ? Has any one else encountered a similar issue ?

The fact that i can still create a standard midi track and route the midi to whatever output i wish baffles me. I have deleted and remade the midi devices etc to see if the prob goes away but no cigar. Nothing has been updated since the setup was working. I am trembling at the thought of maybe having to format and re-install as i have a sizable ammount if plugs etc which will All need to then be updated blah blah blah. So hours to maybe a day for my stuff. Using midi ox i can confirm all midi connections are alive and well. However using the korg plugin stanalones i can create the same issue except it will not respond to any of the usb to midi cables apart from the bcf 2000. I can open say halion sonic standalone and use any midi port available even the ones the cubase won’t…,

So summing up if i cant find a solution then i feel i have two options both not savoury to me. re-install all music sofware i.e cubase and the like, or re-format and re-install windows 7 64bit too. I really hope this is fixable and i have just been a donkey with a setting somewhere but i really cant see what i would or could have changed to make this happen. Maybe it is windows related, i dont know but its enough to stop me writing music and spen all my time fixing which is not good. thanks in advanve to anyone who can elp me on this issue.


There is a limit of 10 (I think) MIDI devices in the Windows. It doesn’t matter if you using them together, or not. Be careful: if you unplug your USB > MIDI device and plug it back to the different USB port, this is count as other, new device!

When you get this limit, you have to delete devices in the Registers, and install again.

What MIDI > USB device do you use?

Hi there,
thanks for the reply. I am using the midi interface on my bcf2000 to connect my fatar sl880 to cubase and i have two usb to midi cables for the two external machines, (xv and gem). The wierd thing about all this is that just last week everything was working 100%. got some time on my hands this week and felt inspired and switched on to find this mess going on. I have looked up today about how many usb devices windows 7 will support and the number is 127 seperate devices, i have nowhere near that. I never unplug my usb connections once installed so as to keep things clean and non duplicated etc. the main issue really is cubase renaming the two usb to midi connection to the same and not allowing me to select the correct one for the right device. I have never experienced this before so this is a new one for me. Maybe some files for cubase have gotten corrupted that deal with the midi i/o etc , but i have no way of checking.

So does cubase only support 10 usb or windows 7 ? I have been relatively lucky as i have not really experienced most of the issues that other users have lately, but i’m worried that as i start to get more heavily involved in sessions etc again that I am going to be spending more time fixing than creating. I think i will test your theory of 10 usb devices and cut back to test this, ( i have just over that including dongles and hubs, mouse , keboard etc)

You DO have 2 ports (in Device Setup -> MIDI Port Setup) each named after the respective instrument?
You DO have 2 devices (in MIDI Device Manager -> Installed Devices) each named after the resp. instrument?

But you cannot select one of the installed devices (above) in VST Connections -> External Instruments -> Add Ext. Instrument -> Associate MIDI Device?

The 10 device limit was supposedly fixed in Vista. I haven’t found anything definitive though.


XP SP3 has a 32 port limit.
The Vista OS has no limits on the amount of ports.
One would presume that Windows 7 continued the trend…

I remember running into the 10 port thing as well, 99% sure that was on W7. For some reason it had created 10 copies of my midi interface (I have only 4 usb ports so don’t ask me how) and I couldn’t get my cc121 to work because of that. The fix was as mentioned above, by getting rid of the keys in the registery.

I think that’s mainly because of drivers though.

I have had plenty of MIDI devices on my system. CC121, Midex 8, CI2 (practiced with it before using it with a laptop), had 8 USB-MIDI cables (class compliant) before they released the Midex 8 driver. All, except the USB-MIDI cables themselves (used a hub), has been connected to various ports (including the hub) on the same computer over the past Windows 7 (64-bit) years. The Midex was used once in one of the front ports (cautious mind, sorry Steinberg) but is now plugged in the back. So at least as far as I can speak for it, there is no such SYSTEM limit anymore, or at least not that I have experienced.

There are two different “limits” being talked about here. Device limit and port limit (one device can have multiple ports - I’m not certain if several of the same type of device, sharing the same driver - count as one or several devices). My understanding is that once upon a time there was a 10 device limit and a 32 port limit. I’m fairly certain the port limit went away. I’ve read mixed reports about the device limit however.


Yes, I was talking about the device limit.
Which shouldn’t be too much of an issue, if you have 10 different USB midi devices you should probably just invest in a midi interface :stuck_out_tongue:

I did, long time ago! :slight_smile:

Hi again,

I had forgotten all about this post, but i can now shed more light and info which will hopefully help anyone else who encounters similar problems. Windows seven indeed installed both my midi to usb cables with the same microsoft driver with nothing to differentiate between the two , so when cubase loads up and looks at the midi ports it only recognises one but with several mirrored ports, hence why it changed them all to the same name. The fix is to get a generic midi driver for another midi cable and install that to the second or third etc cable and cubase then see’s them as seperate ports. (worked for me any ways).