MIDI device no longer recognized

Since a system restart, Dorico no longer recognizes my MIDI keyboard. Sort of.

The keyboard is listed in Preferences–Play–MIDI Input Devices, and the device is checked. But when I play, there’s no green dot, and note input doesn’t work.

My DAW is recognizing my keyboard, so I’m stumped. This is the same keyboard and same computer I’ve been using successfully for several years.

Any ideas? Cross-posting to FB because it’s work time and I need a solution! :grimacing:

Edit: same keyboard, same USB cable, different computer - MIDI works in Dorico.

What MIDI Keyboard?

Long story but I’ll try make it brief.

Some stuff (Cough, Cough, AKAI) just uses really old reference Microsoft drivers for USB>MIDI. They didn’t go in and make them ‘multi-client’ friendly so multiple apps can use it at the same time.

I ‘suspect’ your DAW grabbed the interface FIRST, so now Dorico can’t get to it. Had you run Dorico ‘first’, then the opposite would be true. Dorico would get the events, and your DAW would not.

There are solutions.

One is to simply set up a Virtual port. Launch your DAW First, and arm an empty MIDI track out of the way somewhere that simply takes any of your keyboard input and sends it out that virtual port.

Now Dorico can pick it up off the Virtual port.

Another option is to use something like Bome Translator Classic AND a Virtual Port. Launch Bome First (It has lots of interesting features for making your keyboard a little ‘smarter’). Divert the output of the keyboard into Bome, and then from Bome into a virtual port, and then ALL of your clients can get the messages from the ‘virtual port’.

Are you on Windows or Mac?

If Windows, I recommend loopMIDI for setting up virtual ports. It’s multi-client friendly, secure, and easy to add or remove as many ports as you like, and name them anything you like.

If you are on a Mac (somehow I doubt it, as that wouldn’t be likely use those old exclusive mode MS reference drivers I was ranting about), there are OS utilities for creating virtual MIDI ports. For Macs, it might even be possible to set up a loop-back without the need for Bome?

Thanks Brian. It’s a Roland RD-2000.

Thing is, I do always have this conflict… but here, I was Dorico-only, normal workflow, hadn’t used the DAW in days (and many hours of successful Dorico use since then). When I saw Dorico wasn’t seeing my MIDI, I closed it completely, then opened the DAW… MIDI input works. So it wasn’t a conflict caused by simultaneous programs receiving MIDI data.

Hmm, if you can’t reboot at the moment, sometimes it works to unplug the USB, plug it back in, maybe in a different port even.

Come to think of it I’ve had MIDI just ‘stop working’ at times as well with Dorico 4 in the picture. I didn’t think much of it because I do lots of ‘weird and unconventional things’ with my rig, so I rarely blame a host like Dorico until I’ve uninstalled a dozen things and run it ‘clean’ for a while.

I run MPK2 > Bidule > loopMIDI…it got hung…disconnected it in Bidule, cold booted the MPK2, reconnected in Bidule, and was lucky to get it back without shutting down all my projects.

I recall it happening ONCE when I was in no mood to restart everything and I got ‘lucky’ I guess.

Thanks, this is a new one for me. I tried setting up a virtual port with loopMIDI but still no joy. Thanks for the suggestion.

Another test: plugged in my Akai LPK25. Works in Studio One, doesn’t work in Dorico, even though it’s listed in the MIDI input devices.

So for some reason, Dorico 4 is no longer recognizing MIDI input devices (Dorico 3.5 does recognize the device).

Also tried re-installing Dorico. No joy.

One other idea:
Did you try to rebuild the preferences.xml perhaps?
AppData\Roaming\Doricoxx\preferences.xml
Inside thre is a

<enableMidiInput>


..So perhaps??
Dup

My setup is similar to what @Brian_Roland described above. I used loopMIDI to set up quite a few virtual ports, then Bome to route the signal to multiple MIDI ports at once. All of the following can receive the MIDI signal simultaneously:
Bome

MIDI-OX is a freeware MIDI router. It’s ancient but was still working in Win10 when I last had checked. You could give it a try. Another thing to check is make sure your sound devices aren’t running in exclusive mode. In Win11 this is in Settings/System/Sound then scroll down to “More sound settings.” Select your active device, hit Properties then the Advanced tab. Make sure “Allow applications to take exclusive control of this device” is not checked.

1 Like

Unfortunately I don’t feel comfortable messing with that.

Tried all sorts of things, but still no MIDI input input.

Please post a diagnostics report, Dan. Thanks

One other thing that sprang into my mind. Is your project actually activated? In the top right area of the project window is left to the bar/beat/time display a “power” button, is that active with you?

Yes, indeed, that was going to be my next suggestion. If the project isn’t activated for playback, Dorico will receive no MIDI input: MIDI input is handled by the audio engine and if the audio engine isn’t connected to a project, then no MIDI will make it through.

please help I have a similar issue. I have sound but I can’t put any note with my keyboard

Hi Ulf, yes the project is activated. I’ve emailed the diagnostic report to John Barron; here the link. Thanks.

Hi @Ulf, I’m relieved (or embarrassed) to say that today it works. Nothing changed that I know of.

Sorry. I’d be interested to know if the diagnostics tell you anything. Thanks.

Hi @DanKreider , I’m not 100% sure, but in the Dorico logs I see:
2022-01-30 21:57:20.334 [info] Posting command (requested): NoteInput.ToggleMIDIInput Post=true
2022-01-30 21:57:20.334 [info] Executing command: NoteInput.ToggleMIDIInput
2022-01-30 21:57:20.341 [info] notifyPostCommandExecute: NoteInput.ToggleMIDIInput (7 ms)

So you did somehow actively do something there, maybe not deliberately, but I guess that fixed it…

@Martin_Reyna_Zuniga , first please check in the Dorico Preferences dialog.
Select the Play tab and scroll half way down to the ‘Recording’ section, there is the option ‘Enable MIDI Input’. Is that one ticked with you?
If so, then please do Help > Create Diagnostics Report and post the corresponding zip file here.
Also, please tell what is the MIDI input device(s) you are using.
Thanks

Thank you very much for the attention, my midi keyboard is an axiom pro 49, today I checked the configuration of the keyboard itself, nothing in dorico, and I noticed that the midi output was different, I had selected keyboard instead of USB, this is in the global keyboard configuration, I definitely did not change that configuration, at least not intentionally, on the other hand it is a very specific configuration and not very direct access.

Now everything works, before I made that setting my privia px-5S keyboard and my Komplete m keyboard don’t worked. They only worked when I disconnected my axiom pro. But now everything works correctly

1 Like

Thanks Ulf, I was sure I had done this back and forth several times, but it’s entirely possible it was user error! And that would be the preferable solution…

1 Like