MIDI drag and drop from EZDrummer problem

I have a problem when trying to build up a rythm track by dragging and dropping MIDI grooves from EZDrummer into a MIDI track in the Cubase project window.

I’ll try putting it in reproducable steps.

  1. Create a new empty Cubase project.
  2. Open the VST Instruments window.
  3. Insert an instance of EZDrummer and allow it to create a MIDI track for the instrument, this with default settings should be called ezdrummer 01.
  4. In the EZDrummer interface open the groove browser and drag and drop one of the MIDI grooves onto your newly created MIDI track.

The result of this depends on the setting of the preference - Auto Dissolve Format 0

With Auto Dissolve Format 0 checked the MIDI track you dragged the MIDI file onto will retain its name and the MIDI part will take the name of the track but there will be a new empty MIDI track created with the name of the MIDI file.

With Auto Dissolve Format 0 not checked there is no empty MIDI track created but the original MIDI track will change its name to that of the MIDI file and will keep doing it for each groove dragged to it.

I find this behaviour a little unexpected.

Searching Google returns a few forum posts relating to this on this forum and others but no satisfactory answers. Although reading those posts it seems it isn’t just Toontrack products that this happens with as Stylus RMX is also mentioned.

Any help would be appreciated.


How does this work with an instrument track?

I’ve just tried with an instrument track and it exhibited the same behaviour.

I then tried dragging a MIDI file from the desktop and regardless of the Auto Dissolve Format 0 setting there was no new track created but the instrument track was always renamed.

I can understand if importing a full MIDI file containing multiple instruments the desire to have new tracks and have them individually named but it seems counterproductive when trying to work with a single MIDI/Instrument track and build up an arrangement from smaller building blocks.

Wow! I can confirm the behavior with Auto Dissolve 0 activated! What’s with this?

I can’t try it without Auto Dissolve activated because it seems I have an old Nuendo/Cubase bug of it staying checked after applying and closing the preferences.

It would be nice if you could drag and drop a MIDI file/pattern onto an existing MIDI or Instrument track, instead of it going to the bottom of the list.

Is this a bug or expected behaviour?

Richard: It’s no Bug.-----I drag and drop Files From Toontracks SP.2
(the Big Brother of EZ drummer) practically every day. Create an
Instrument Track and Drag it into Cubase . Make Sure EZ Drummer is
in your VST Instrument List. Cubase is the Host

Jack :smiley:


I don’t have a problem with the MIDI being imported as such it is what happens with the MIDI/Instrument track as the MIDI is imported.

I also have Superior Drummer 2 and it exhibits exactly the same behaviour as my first post.

I can verify this in Cubase Essential with EZ Drummer Lite.

It would be ok if there was just an option to not allow the track name to change, with that and the Auto Dissolve Type 0 setting checked it would improve workflow greatly.

I know this is an old post, but in case anyone’s looking for this, I got this working by not only unchecking ‘Auto Dissolve Format 0’, but also unchecking ‘Import dropped File as single Part’. Unless both of these are unchecked, dragging from Superior Drummer 2.0 always caused a new track to be created. Now it simply drops the part wherever I want.



Yeah it works how I would like it to now, a new track is not created and the existing tracked is not renamed to the name of the part being dragged. I dunno what my settings are compared to defaults as it’s been that long but Cubase is 2 major revisions and EZdrummer is 1 major revision on.

You made my morning with this tip … thanks!