Midi Drums

Has anyone came across this issue before please.when i import a midi file even a professorial made one i have paid for the drums do not snap in time if i quantize then the fills or some beats don’t have the same feel but some are still off time a bit, i have to go through every single drum sound and change it one by one.please help someone this also happens in cubase 7 and 7.5


You really are going to have to give more detail than this.
Midi drums (vsti) you are using?
Have you looked at the Quantise set-up?

the nature of quantizing is to constrain all midi notes to specific times of course you will lose the “feel” if you quantize your purchased track. the “feel” is achieved with some notes lagging or advanced in time. quantizing removes/fixes this.
if you want to change the tempo then simply change the tempo. if you are trying to make the midi track fit the tempo of an existing audio track then you must either strech/shrink the midi track or strectch/shrink the audio track depending on what needs to fit what. simply stretching/shrinking the audio track doesnt always work as the “feel” of the midi track may or may not line up properly with the audio. this requires creating a tempo track from the audio material by assigning “hit points” to it then the midi will follow this “variable” tempo track. its not a perfect science and depending on the material can be downright next to impossible. lol good luck and happy holidays :smiley:

Thanks guys.i use cubase pro 8 and 7.5. I import a midi file let say eric clapton knocking on heavens door.i then change the drum track to use Ez drummer 2.but the hi hats will be off time and some snares bas drums not off by much but they are off a bit i have not looket at the quantise setup.i just leave set has default.i just thought it would snap all the drums in time but it dosent and thats my problem.it also doubles a few up so there will be 2 or 3 diamonds on top of each other in the drum editor.i find it odd.you should try it see if dose it on your system.i thhink my pc is ok its a quad core intel i7 16gb ram.windows 7 ultimate.it will save me lots of time if i can sort this issue.thanks for the help very Greatfull and have a great christmas :slight_smile:

+1 Great explanation. You should not be quantizing drum tracks (unless the robotic feel is what you are after!).

Does your track sound fine before you switch to Ez-Drummer? Just trying to isolate the issue…


Thanks John,

i have just tried inporting the midi file and the drums are off time before i do anything to it.

i have just found something very interesting though.

1.i imported a drum fill from Ez drummer 2 and it was off time has it always is.when i say off line i mean not on the grid lines i have took a screen shot so you can see what i mean.

but this the interesting part.

  1. if i change the grid in the quantize panel too 1/16 and Quantize the drums snap to the grid lines so look perfect in time.and it also sounds right when i play it back.great!!!

    2.if i change the grid to 1/8 and Quantize it snaps the drums in line with grid lines but it dose not sound right any more. very interesting might be on to something here? thanks again


It sounds as though that something (quantizing?) possibly is happening during the import. By quantizing the track to a lower threshold - 1/16 vs 1/8 it seems to improve the issue.

Couple of questions:

  • When you say “import” do you mean the option on the File menu - Import Midi file?
  • Did this work under previous version of Cubase for you?

I use SD2 and drag and drop midi files - which works great for me. Not sure if you have a drag and drop function in the program that you are importing from.

I checked and could not see any options that quantize during import - but this is not my area of expertise as I do not quantize anything.


i think you are right John, i do agree.

That’s right i just use the file Menu and import midi file.

and yes its always worked via file menu/import midi.

i only noticed the drums off time from cubase 7 7.5 and pro 8 and that’s my best mate is a drummer and he told me about it after he listened to a track i sent him.

no you cant quantize during import you are right.please forgive me John but what is Sd2 never heard of it.

thanks again for your help so far i think im onto something though now hopefully its’s a very odd its annoying too when you have spent lots of money on this software and it is has these issues but i do love cubase and will always stand by it.

i still find it odd that it dose this though i was hoping cubase pro 8 wouldn’t do it but it dose.


i get you now John sd2 sorry im very tired.

yes i can use drag and drop from Ez drummer 2 but its still off time.and the main reason i use midi files that have been made up is cause i edit them to make better backing tracks to use on stage you see.so thats why i need to use the midi files.


I do not use the drum editor - not sure if that is automatically applying quantizing.

I usually drag and drop midi files from SD2 and edit in the key editor. Maybe try this and see if it acts differently? May help to point you to where the issue is occurring.


One other thought - are you sure that you are lining up the imported / dragged and dropped midi file to the beginning of the grid? I usually use the snap function to ensure that this is happening.

Just quantize using 1/16 or even 1/32
In Cubase 8 you can make a tempo track using midi, if that doesn’t work, do a render in place, and make a tempo track from the resulting audio track. Then the click will follow the drums. Watch the videos about Cubase 8, and look up tempo track in the manual.