MIDI editing question: Window chase song position?

When double clicking a midi part the key editor opens up at the current song position as expected, all good.
Then I single click on another midi part on another track to make that active in the existing editor window, but the editor chases to the start of the midi event (block) rather than the song position. Is there a way to change this behavior so it just goes straight to the song position?
The (annoying) workaround is to press play and stop quickly so the window chases to the song position, i’m using external editors rather than the lower zone editors.

Hi,

Just double-click to the 2nd MIDI Part too.

Thanks Martin, just tried it now as per below, Single click, double click, makes no difference.
Example, with Cubase Stopped at bar 49 and no midi editor open, UI zoomed out to see entire song:
Double click a violin midi event on a track.
Editor opens at bar 49 with the violin part.
Leave midi editor open and single click (or double click) the Cello part on the cello track
The editor which is still open changes to show the midi in the cello part but not at the song position (bar 49), it goes instead to the start of the event (in this case bar 1). The editor is not chasing the part to the song position like it does in the first instance.
The only way to do so is to press play and stop very quickly so it chases to around bar 49.

Hi,

Is the cello MIDI Part present at bar 49, please?

Do you open the Key Editor in the lower zone or in the dedicated window?

The double-click closes and reopen the editor, in fact. Therefore it should work (and works here on my side).

Yes, the midi parts are all the same length pretty much. I use external editor (not lower zone), but it was doing the same thing in lower zone.
Here is a screen capture video of the issue (no sound). The video is a bit blurry but at 15 seconds it gets sharp

https://www.dropbox.com/s/oyptnkjnne03zd4/cubase%20video.mp4?dl=0

I mix and edit on a second screen, but for this demo video I had to put everything on one screen for recording.

  1. You see the song is at bar 49. I double click the flute part and it opens at bar 49, perfect.
  2. Next, i leave the editor open and click on the Oboe part. The editor changes to the oboe part, great, but it does NOT go to bar 49, it just displays form the start of the part (bar 1), NOT bar 49. The editor is NOT chasing or syncing the view to song position to bar 49 like the flute.
  3. Next i press play and stop very quickly, and only THEN will the editor chases to bar 49.
  4. I close the editor and repeat - Flutes open to 49, great.
  5. Then i click oboe, goes to the start Bar 1.

If i close the editor and double click the next track it’s fine of course but it would be great if the editors would sync view and song position as well as the part. Maybe there is a setting i missed to change this?

Hi,

Double-click instead of click here, please.

As i said before, single click, double click, does not work, I made a new video here with all double clicks!

https://www.dropbox.com/s/ns7hez0m4rs503j/Cubase%20Video%202.mp4?dl=0

If the editor is closed, double click opens perfectly, but if you select another mid part while the editor is open, it will update to show the contents of that new part, but it will NOT chase to the song position like it did the first part. The workaround is to press play then stop.

What would be great is a ‘Sync editor views to song position button’ in preferences (so this would chase to song position and also sync the zoom setting.
Is there anything else i can try? Meanwhile i’ll go and post this in the bug/suggestions forum.
Thanks for your input Martin, i appreciate it :smiley:

Hi,

Could you share your preferences folder, please? I’m just wondering, if this could be affected by any preferences settings. I had this issue in the past quite often, but now it works like a charm here to me (finally!).

If you want to link the Project Window and Key Editor Zoom settings, click to the chain on the left side of the Auto-Scroll in the Key Editor. The button is named Link Project and Lower Zone Editor Cursors.

Rexxy, this drives me nuts too. Check your Preferences/Editors…‘Editor content follows event selection”. If checked, I think Martin’s double click will work? But, I prefer to leave it unchecked which allows for multiple Key Editors open at once. I’m not at my DAW so I’ll try it tomorrow. Anyway, another work around is to toggle the Auto Scroll button on/off. Works every time, but is another extra step requiring two mouse clicks. So I use an iPad with Metagrid to trigger such things. I can’t remember all my key commands so Metagrid is a lifesaver.

Yeah that is always checked here. I have a workaround of course, but if the editor can update the contents, you’d think it could be coded to also refresh the song position. My auto scroll is on, but i need to hit play and stop for the chase to happen. I’ll be right, it’s just a niggle!! Hopefully they get to it (all posted in the suggestions page).

Hi,

I have tried once again. Now on Windows system. The result is always the same. When I single-click, then it doesn’t work and the beginning of the MIDI Part is present in the Key Editor. If I double-click, then the area of the cursor is present.

You can see it clearly. If the Key Editor is in focus (so there is the white frame around), then you double-clicked and you should see the surrounding of the cursor.