Midi editor - strange things

funny things happen.
I have inserted a midi file with drag and drop.
Then VL crash, restart, ok so far.
When I open the midi file in the editor, it doesn’t show what is playing.
I think it shows the last midi file with the same name.
very confusing.

Have you already tried to import the MIDI file?

Crashes are not ever ok, so if the problem persists pls. let us know and if possible send the midi file in question.
But first:
a) Do you use the latest version (see vstlive.net)? We did fix MIDI Import problems
b) if you use “File/Import MIDI file” instead of drag and drop, same behaviour?


Here the screenshot, very strange. Here you can see the midi file (midi track and editor)!!!

Did not crash anymore. Drag and drop or import load: No difference.

Hello Michael,
as you can see, the midi file is opened in the editor, the correct midi file is played back but not shown in the editor. The track view is also correct. Have you already analyzed the error?


This problem has not been solved yet.
I can not edit the midi file because it is not displayed correctly.
What should I do, start the project again from the beginning?

Sorry, did you send us your midifile already? Was ist drum120.mid? No problems with that.

Hier das projekt:
the net¦dreaming awake¦circles¦20230424¦.zip (1.6 MB)
ohne audio und video

I can play it just fine. Actually, for the 2nd song and its “da-click” track, the Midi Editor shows it as heard, only the track display is folding the high notes an octave down so to display as much info as possible.

I’ll build a new song from scratch.
Midi files plays the right notes but in the editor they are not shown correctly so i could net edit the midi notes. See the picture on first post. I have a 3/4 and in the editor it shows 4/4. That’s really confusing!!!
I will send you the original project with the original midi file this evening. With the issue.

look aftertouch.project i send to you yesterday

opening Dreaming awake Da-click, no problems.

Great :wink: