MIDI event trim does not stop midi notes from playing

Hey there,

I’m new to Cubase 12 and I’m struggeling with this problem right now:
When I trim a MIDI event to a certain length with midi notes overlapping that end border, the notes keep playing for their actual length. The result is that the trim doesn’t have any effect.

I’ve found two options through another forum post but they don’t seem to make any difference.
Preferences-Editing-MIDI: Split MIDI Events & Split MIDI Controllers.

I think this is by design. It has always been that way.
You could select your MIDI notes and cut them using the Cut tool.

Trimming a MIDI Part won’t cut the notes that extend beyond the end, they will always keep playing for their full duration.

Those Preference settings apply only when you use the scissors tool to split the event into two, not when you resize the event.