Midi fader not moving with CC7 but I HEAR it working?!

Hello all,

First time Cubase 7 user here and trying to figure out what is probably a simple thing. I have my midi controller sending midi CC 7 on a fader (volume) and I have a midi track playing a Kontakt VST instrument. On the midi track I’m changing the value of the fader on my controller, and I hear the changes (up it gets louder, down its softer) but the actual midi fader in Cubase isn’t moving at all! It just sits at 100 (which is where I set it by default).

Any ideas what I’m doing wrong?

How exactly did you set up the remote device? What exact parameter did you set it up to control? The fader on a MIDI track in Cubase is a little bit… tricky. :slight_smile: That fader will send CC7 messages to the instrument it is connected to, meaning that if you move that fader (and the instrument supports it) you will be effecting the volume of the sound on the designated MIDI channel. However, this is only a one-way communication. IF, for example, you go into the instrument itself and change the volume of that sound (the same control that would be effected by that MIDI fader in Cubase), it WILL NOT change the fader position on the MIDI track, because the instrument isn’t sending MIDI back to Cubase’s mixer to tell the fader where to go.

In that instance, if you’ve changed the volume on the instrument directly (without using the MIDI channel fader), and THEN move the MIDI channel fader in Cubase, the volume on the instrument will then JUMP to wherever the MIDI channel fader is once you move it.

This is just a long way of explaining a possible reason you’re not seeing the results you anticipate. It depends on what exactly you’ve set your controller to control… If it’s sending it’s CC7 message directly to the instrument (say through Cubase’s Device manager and not through the MIDI input on the MIDI Channel), the Cubase MIDI channel would not see that message. In that case, the volume would indeed change, but the MIDI channel fader would not move. There’s nothing really wrong with this, per se… your controller is still working. And if it’s a matter of wanting to automate the volume using your controller you can still do that, it just leaves the MIDI channel fader out of the loop, and automates the instrument volume parameter directly.

To beat a dead horse and clarify further :slight_smile:, in order for your CC7 changes to be reflected on the MIDI channel fader, that CC7 message would have to come in through the MIDI input of the MIDI channel itself. If your controller is sending those messages through some other means (through device manager, for example), you won’t see the fader move.

There MAY be a way to get your controller’s messages to go through the MIDI track but depending on how it works you then MIGHT also be faced with the possibility of recording your controller’s remote control data onto the MIDI track along with the notes, etc. and… you probably don’t want that…

You mean, you don’t see the MIDI fader in the Cubase Mixer (and in the MIDI track’s Inspector) moving?
This is normal, in the following circumstance (which is in fact the most likely case anyways :wink: )…
CC#7 (and in fact, any CC#) can be recorded either directly into the MIDI Part (where you can see it in the corresponding Controller lane in the MIDI Editor), or… it can be recorded as Automation (see MIDI Menu>CC Automation Setup).
It is only when using that 2nd option that you will see the fader move.

HELP - I have the inverse problem.

I’ve set Kontakt instrument’s CC7 to volume. But when I move the midi fader I don’t see any message being rcvd by kontakt or it having any effect whatosever.

Does it need to be enabled in some special way? Isn’t it just standard MIDI CC7?

Strange… it works ok here.
Does it work if, instead of moving the fader, you create some CC#7 data on the MIDI track?
(and… just to be absolutely certain, have you tried routing that MIDI track to a different VST Instrument?)

Not sure if this answers your question, but it may make a few things clearer:

https://www.steinberg.net/forums/viewtopic.php?t=59819&p=360816#p360816

Near the bottom of the first page, and into page 2, I passed on a couple of tips - may be your solution

also, have a look at Kontakt itself - you should see its fader moving

Neil

IN my case it was because Kontakt was hosted under VE Pro and it required the parameter in VE Pro to be mapped to CC7.

I found it easier to simply map all audio channels to seperate outs in VE Pro and automate those.

Here’s one for you guys, I exchanged the silver stock fader on the cc121 to be cute and put on a blue colored one from an allen & heath and later noticed the fader no longer sent any midi message to Cubase. The fader would fly on cc121 if I moved a fader in Cubase with the mouse but not the other way around. So The Moral Of This Post : If it ain’t broke …don’t fix it ! The silver colored stock fader acts as a contact like also your finger on an ipad.