MIDI Files - Data missing?

I’ve got a Midi file (got it free online). It has a nice triplet feel to it. When i use the standard ms GS Wavetable Synth sound, it sounds (feels) like it should sound, yet when i change this to Halion, it’s like its lost data. The triplet feel has gone and so has some of the other data info. What am i doing wrong, or what do i need to do?
All advice appreciated. Thanks in advance

It depends on the sound that was chosen / does it have suitable parameters for your Midi data

If the midi file contains an Expression pedal (CC#11) Data
And you run this Midi file using an instrument that does not contain any Parameter linked for CC11
This information will be without the slightest benefit
On the other hand
If the sound / instrument has a parameter linked to CC11, you will hear the effect moves based on that information coming from the MIDI file.

Sorry for my bad English :pray:

This triplet feel you mention kinda sounds like MS GS struggling to keep up with the MIDI file…

If you message me this file, I can try to analyze it and tell you what’s going on.

Its fine on ms GS wavetable (in Cubase). It’s when i get halion to play the same file that it seems to have lost some data. Happy to send the file to you anyway.

Everybody-Want’s-To-Rule-The-World-2B.mid (38.0 KB)

The Midi file is imported into cubase and when i play it in cubase with ms gs wavetable synth, it sound like it should. The moment i get Halion to play it, that’s when it does not sound right. Thank you


I don’t know the song, but it sounds right to me, if I use HALion Sonic SE.

Could you export an audio and share it, please? Or at least export the HALion Sonic SE version to be able to confirm if I can hear the same or something different.

Hi Martin,
Yes sure. Please find attached a short mp3 version of each


Hi, The midi file looks and sounds as expected here for what it’s worth.

First one doesn’t have any sound for me.

My file, when i uploaded it, didn’t quite come out like that. The drums were all on one track.
Like I’ve said it sounds ok using ms GS Wavetable but not when i change to Halion. Not sure if it has something to do with midi excl messages!

Make sure the drum track is midi channel 10.How did you import it to cubase? I used Import midi file function in a blank project. (Under file menu-Import-Midifile)


I get the same result.

This looks like a pretty simple MIDI file. There’s nothing in it that could possibly trip up Halion Sonic SE. There’s no SysEx messages.

If you have your MIDI import options set to “MIDI tracks” instead of “Halion Sonic SE multi-timbral”, select all MIDI tracks and hold Shift + Alt while selecting your MIDI outputs to route all tracks to Halion Sonic SE.


In Halion Sonic SE’s “Options” tab, make sure that the Program Changes mode is set to GM Mode. This also makes HS SE use the correct settings for General MIDI playback.


Sorry for late reply. i just loaded up an older Project, closed it then opened the offending file and it worked.