MIDI for step input works but NOT for real-time input

Hello,

I was trying to set up Virtual Midi Piano Keyboard (VMPK) so I could do real-time MIDI recording using just my laptop keyboard. When loading Dorico, I can see the green light in the bottom right indicating that I’m inputting MIDI when I press the keys. I can even hear the samples play back correctly. However, when I press record and play some MIDI, the notes are not written into the software.

Real-time MIDI input is enabled, and so is the virtual MIDI device. Step input also works perfectly using the VMPK software, so I don’t believe it’s an issue with that software.

I also had a similar but separate problem when using a Bluetooth MIDI keyboard to do real-time input. When I would record, the notes would be several measures ahead of where I had finished recording. They would also be stacked into one chord instead of played one note at a time over multiple different note durations. Weirdest thing yet: the Bluetooth MIDI keyboard, like the VMPK software, also causes the green light to light up in the bottom right during input. The keyboard also does step input just fine, and the right notes are being played within Dorico.

I opened up the temporary folder (“open $TMPDIR”) where Dorico holds real-time MIDI input data, and upon opening those files, they were either empty of MIDI data (when using VMPK) or reproduce the same errors in notation (when using the Bluetooth MIDI keyboard).

I have provided a video of me reproducing the problem (do not worry about the sound; I was not able to record sound via QuickTime screen recording, but I do hear sound on my end). I have also provided a diagnostics report and an example MIDI capture after testing.

When recording MIDI with these devices into REAPER, a digital audio workstation, they work just fine; no issues occur. It only happens in Dorico.

I am running Dorico Pro 5.1.21 on an M1 MacBook Pro running macOS Sonoma 14.3.1.
Dorico Diagnostics.zip (436.9 KB)


capture 0001.mid (124 Bytes)

Update: I have just tried using a macOS-only application, MidiKeys, to do the same thing as VMPK. Somehow, it worked; I was able to successfully record MIDI data into Dorico! However, Bluetooth MIDI keyboard is still having issues. Thankfully, I can just connect using USB, but I think if I encounter more issues using a Bluetooth MIDI keyboard, I will make a separate thread.

Welcome to the forum, Carlos. I wonder whether VMPK might be sending a lot of continuous data into Dorico, and that’s mucking things up? You could try activating the Filter our MIDI controllers option on the Play page of Preferences to see if that helps.