MIDI Geräte ohne Neustart erkennen?

Hi zusammen,

habe das Problem, dass mein Novation Impulse Keyboard des öfteren während einer Session nicht mehr erkannt wird. Bringt auch nichts die Software zu updaten oder nen andren USB Port zu nehmen. Vielleicht ein Wackler oder so. Es geht zwar nicht aus, aber plötzlich kommt kein MIDI Signal mehr in Cubase an.
Wenn ich Cubase neu starte, dann ist alles wieder ok und ich sehe den MIDI-IN Ausschlag im Transportfenster.

Blöd ist nur, dass es mich bei großen Projekten 15 Minuten Wartezeit kostet, bis Cubase wieder neu gestartet hat.


Gibt es ne Möglichkeit die MIDI Geräte neu zu “scannen”, so wie es auch Cubase automatisch beim Startbildschirm macht, ohne aber Cubase neu zu starten? Zum Beispiel im Gerätemanager etc.?

Gerätemanager hört sich nach Windows an…

Beim Mac reicht es, das Audio/MIDI-Setup aufzurufen und die MIDI-Devices erneut suchen zu lassen. Cubase kann dabei gestartet bleiben und man kann die Auswirkungen unter “Geräte konfurieren” -> MIDI sogar sehen.

Evtl. geht das bei Windows ähnlich … k.A.

Zum Thema Impulse gibt es bereits einen threat. Problem ist tatsächlich die schlechte Stromversorgung über Usb. Allerdings hilft oftmals auch, Impulse auf die Werkseinstellungen zurück zu setzen.

Das Problem existiert schon seit Jahren und wurde auch wiederholt thematisiert (unter anderem auch von mir). Leider gibt es anscheinend in Cubase bisher keine Lösungsmöglichkeit.
Ich hatte früher auch ein MIDI-Keyboard, das ständig die Verbindung verloren hat und habe mir deswegen ein neues kaufen müssen. Jetzt habe ich zwar keine unterbrochenen Verbindungen mehr, trotzdem nervt es mich, dass Cubase Geräte nicht erkennt, wenn sie erst nach dem Cubase-Start eingeschaltet werden. Ich habe gelesen, andere DAWs hätten damit kein Problem. Man hat ja bei der Arbeit nicht ständig das Keyboard eingeschaltet, wenn man z.B. mixt, arrangiert oder Mikrofonaufnahmen macht. Dann hat man in einer solchen Phase eine Idee, die man mit Keyboard schnell realisieren möchte. Das bedeutet: Song speichern, Cubase herunterfahren, MIDI-Gerät einschalten, Cubase starten, Song laden. Da können schnell mehrere Minuten vergehen. Bis dahin ist die Idee vielleicht schon auf dem Weg ins Gedächtnisnirvana.

Danke für die Antworten.

Ich habe über die Boardsuche zwar zwei Einträge zu dem Thema gefunden, aber genau dasselbe Problem war das nicht.

Wenn es bei andren Sequenzern funktioniert, dann schreib ich mal den Support an, ob die das nicht im nächsten Update mal versuchen können.
Weil es ist für mich ne Katastrophe wenn ich nen Auftrag habe und dann nach ner halben Stunde Arbeit wieder 15 Minuten rebooten muss…

Gute Idee.
Aber mal ne andere Frage : brauchst du wirklich 15 Minuten zum rebooten?! Stimmt evtl mit der Konfiguration etwas nich, und ddarin liegt der Grund? (nur eine spontane Idee)

Ja, leider dauert das so lange. Weil ca. 14 GB Orchestersamples in den RAM geladen werden müssen. Wenn ich ein Rockprojekt oder so mache dauerts natürlich nicht solang.
Der Neustart von Cubase an sich dauert natürlich nur ein paar Sekunden. Aber das laden des Projekts dauert je nach benötigten Samples im RAM umso länger.

Habe den Support kontaktiert und werde die Antwort reinstellen.

Hallo Arminas,

Vielen Dank für deinen Thread.

Hast du eine Fallnummer?

Für weitere Hilfe stehe ich Dir gerne zur Verfügung.

Mit freundlichen Grüßen,

Marcel // Focusrite Novation Support

Eine Hilfe wäre es, wenn mal ein paar Automap-Bugs beseitigt werden würden!

Also ich war mal so schlau und hab mir vor langer Zeit das ESI M4U XL (ist an einem USB-Port) gegönnt. An diesem Ding hab ich jetzt mein Masterkeyboard und diverse andere Synthis über MIDI dran. Kann von daher zu jeder Zeit eines dieser Tastaturen oder Klangmodule anmachen und habe sofort eine Connection mit Cubase. Kein Neustart oder dergleichen…ist also permanent in Cubase präsent.

Nur mal so als Info!!