Midi Import Problem - Need Help Please

I’m currently in talks with Steinberg support about a midi import problem, but they can’t reproduce the fault on their system.

Can I ask a few of you with Cubase 6.0.2 and Windows 7 to try and import a midi file into Cubase, without first loading a blank project, and with the Halion Sonic SE as the destination as set in Preferences - Midi File.

When I try this, the voices from the midi file do NOT load into Halion Sonic SE. If I load a blank project first, then the voices load normally when a midi file is imported.

Many thanks, Glen

My guess is that without first having a Project then Halion SE has also not been opened and is therefore not seen as a destination.
Seems normal to me.
Did it used to work that way in C4 or C5?
For a single user I can see this being handy but in a studio where there may be several operators there would be no way that Cubase could read what each user intended so leaves the canvas blank.

Steinberg Support says on their system loading a midi file without loading a blank project first, it loads OK and fills the Halion Sonic SE with the correct voices - on my copy it doesn’t. So my request is to see if other people are having this problem, or is it just me !!

The only reason I would ever load a midi file without first loading a Project is to listen to a number of midi files with the Halion Sonic voices - i.e. using it as a midi file player.

I’m sure this worked from the initial DVD install, but since installing both patches its no longer working, even after uninstalling Cubase 6.0.2 abd reinstalling the DVD 6.0.

Just asking for someone to try it please.


Hi Glen,

I believe when you load the midi tracks as vst instruments tracks then it works. Loading everything with one ibstance of Halion Sonic SE is a little problematic somehow. I don’t have all the info here at the moment.



Hello Glen,

When I import a MIDI file without loading a blank project first in Cubase 6.0.2 (Win7/64), the sounds from the midi file do NOT appear in Halion Sonic SE.

When I set the Preferences > MIDI File > Destination > Instrument Tracks, the tracks will load with GM (General MIDI) presets in different Halion Sonic SE instances.
Instrument Tracks do not support plug-ins with multiple outputs, so all the MIDI tracks in your MIDI file will load into different Halion Sonic SE instruments, and they will all play on MIDI channel 1.

But why would you use Cubase as a MIDI Player?
I suggest you try ‘vanBasco’s Karaoke Player’ (freeware: http://www.vanbasco.com/ ).
It’s a nice player, opening and playing standard MIDI (.mid, .midi, .rmi) files in less than a second.
You can mute one or several instruments, or solo an instrument, and there is even a ‘Piano Window’ that displays the notes in real-time.



Thanks for your comments.

Hopfully if this is a known problem with the Halion Sonics Multitimbral function, Steinberg will fix this in a future update, as its a very useful function to have.


I appreciate you trying this out, many thanks - at least its not just me.

I have tried Vanbasco Midi Player, and as you say it is very good. But if the Halion Sonic SE loaded as in my post above, then why not use Cubase as a midi player, you would also get the great Halion sounds. Using Instrument tracks works great but they do take a short time to load, thats where Vanbasco would be better.


But if the Halion Sonic SE loaded as in my post above, then why not use Cubase as a midi player

The programmers probably thought there were cheaper or free alternatives than a $700 program just for that.
ie: not a primary consideration in a DAW aimed at the professional audio engineer end of the market.

Although there probably is an easy answer the only thing I can think of is to direct you to the help button in the Prefs.