midi input - caret does not advance

Hello, since a couple of days I have Dorico behaving strangely whilst inputting notes via connected midi keyboard. The notes do play back - but the caret does not advance nor are any notes put into the score.
I close and restart Dorico, it works again as required. After a couple of hours not working with Dorico: same procedure again, Dorico will not receive the input notes - even if they do play back.
Is there an easy way to solve this?
So far I never had problems in this way, may be the issue occurred when Dorico 3 introduced midi hot-plug capabilities…

[edit] now this even happens while I input music. Suddenly the caret does not advance and no music is been taken in by Dorico - very strange.

A few other users have reported this problem, e.g. in this thread. As yet we don’t have any leads on the problem, because we have been unable to reproduce it in-house, but we know there’s something lurking here and obviously we hope to resolve it in due course.

Thank you Daniel,
I don’t know wether it is helpful, should I send a diagnostic report next time it happens?
I’ll do, just in case.

Unfortunately so far none of the diagnostic reports we’ve received have given us any clues as to what’s happening when this goes wrong, but certainly it can’t hurt. Please make careful note of the exact time at which the input stops working as well, and provide that along with your diagnostic report.

Daniel, today the input stopped (whilst re-inputting pitches) at 11:29 European Time.
Just in case I provide you with the Diagnostic report:
Dorico Diagnostics.zip (1.06 MB)
I take it as an opportunity to have a break :wink:

I think I’ve mentioned this on one of the other threads, but if not, I’ve experienced the same thing. I think it only happens to me whenever I’ve had two projects open and tried to switch between them. Any time I only have one project open it doesn’t seem to happen. It’s very rare that this is the case (typically just copy and pasting certain bits to a new version of the project) and as I haven’t needed to do that in a while, this problem hasn’t manifested in a while. Fortunately restart always resolves the issue.

I’ve had it happen many times with just one project open. I also have sporadic save errors, but another control S always saves successfully. Probably unrelated?

Just happened to me again. Totally out of the blue, first time in quite a while. Only had one project open (so my earlier theory seems debunked) and it was only about 20 minutes old, totally native to D3. I noticed that the midi indicator down in the corner was no longer active, although another program that was open was still receiving midi signals from my keyboard just fine.

(I run Hauptwerk organ software in the background with my playback template set to silent. I have been able to run these two programs simultaneously without incident since the very beginning of D 1.0 so there seems to be something that has changed in D3.) Diagnostics report attached.
Dorico Diagnostics.zip (837 KB)

And just happened a second time. This is so weird… this hasn’t happened to me in weeks, and now twice within the hour. I typically don’t use multi-stave input but I’ve been using it today to compose. That is literally the only thing different in my behavior today and my computer has been restarted within the last 24 hours.
Dorico Diagnostics.zip (833 KB)

Sorry I opened a topic without knowing there was already this one.
My case is: caret moves but no notes written on the score. Nor I hear any sound matching the notes I play on the keyboard. On the other hand mouse input works and I can hear the sound.
It happens random, but only while modifying some music I have already written. Both with Dorico3 native files or not.
Restart Dorico would not be of any help.
Only solution I found working for my case: opening a new project and go back to what I was working on.

As you can see above, this has happened to me multiple times and a restart has ALWAYS fixed it. Look down in the right corner the next time it happens and check to see if the midi indicator lights up or not. In my case, it stops lighting up. When it happens again, upload a diagnostics report (Dorico will generate a zip file natively and put it on your desktop so you can upload it here).

I see there has been no permanent solution to the problem.

This has been fixed for the next update.


This is great good news!