MIDI input not working - has a "[1]" annotation

Hi, it’s been quite a while since I used my midi keyboard with Dorcio (I think last time was 3.5) and today I noticed it’s no longer recognizing my midi inputs. I am seeing a “[1]” marker at the end of my midi input name, not sure if that means something special as not all midi ports have it.


Using Dorcio 4.3.11 - any help is greatly appreciated!

Looks like you are on Mac, right?
If so, please go to /Users/yourname/Library/Preferences/Dorico 4 AudioEngine.
In there is a file called PortSetup.xml.
Stop Dorico, rename that xml file to something else, e.g. _PortSetup.xml and start Dorico again.
Any better ?

(If on Win, that same file lives under %appdata%\Steinberg\Dorico 4 AudioEngine)

Thank you @Ulf . I’m on Windows. Unfortunately, this didn’t resolve the issue. I renamed the file and restarted with no effect. I even restarted my computer and saw a new Port Setup.xml file created. Still the input remains selected and with a “[1]” annotation and doesn’t pick up anything on that port. I verified that midi (and midi through) is enabled.

I double-checked the port itself by:

  1. Closing Dorico
  2. Opening Kontakt
  3. Turning off all midi inputs inside Kontakt
  4. Turning on the “LoopMIDI Dorico” port inside Kontakt
  5. Verifying that Kontakt receives midi data [success!]

So, the virtual port is working fine in Kontakt, not sure what is going on with Dorico or why the port is annotated in Dorico. (Side note, some other ports I don’t use are also annotated in Dorico, including my midi controller which has a “[2]” annotation.) I believe this started in Dorico 4, I’ve been using my computer keyboard for a long time and just now tried the midi controller to find it’s not working.

I also tried creating a new virtual port called “LoopMIDI Dorcio (new)” and was not able to receive any midi data on that port.

In fact, I turned on many ports/devices, including the direct hardware controller devices listed and Dorico is not receiving midi data from anything!

Alright, I kept at the problem and “got it working” but it may still be something you’d like awareness of.

  • I had a 2nd virtual midi system running which I no longer use. It’s been running for a long time so it shouldn’t have made a difference, but… I uninstalled it and rebooted again.
  • The new “LoopMIDI Dorico (new)” now works while the original “LoopMIDI Dorico” port does not. Both have the “[1]” annotation. This new port only started working after I reboot my machine.

So, I’m good to go now but it’s very odd that Dorico was complaining about things when other programs were completely happy with my virtual midi ports. Just something to be aware of!

I’m glad you’ve solved your problem yourself. I don’t know that LoopMIDI system, so can’t say something about it, only that to my knowledge no one else has ever brought forward this issue here in the forum. Let us know should the problem return, then we can have a deeper look.