MIDI input split point issue?

See below. This happens from time to time. I’ll be doodling along just fine in real-time MIDI entry, stop the recording, then pick it back up (at third bar in the example below), and it refuses to distribute to two staves.

When this happens (and it’s hit or miss), I can’t restore the multi-staff real-time input for that instrument. Anything I’m missing?

That’s happening to me too … But I don’t know any answer… sometimes quit and restart can help, but not always(?)!

It will depend on the selection you have before you start recording. If you have the caret visible, then it will record on just the staff on which the caret is shown (and extending the caret across both staves won’t currently have the expected effect of allowing you to input across both staves as you can when using step-time input, though that is planned). If you have just a note or rest selected without the caret being shown, then you’ll record into both staves.

Ah, of course. It’s so simple. Thanks Daniel!

The possible benefit of being in note input during MIDI recording is that you can then specify the voice into which you want to MIDI record the notes.

Got it too, so please excuse me asking …

Not a problem at all, it’s always useful to know when multiple people experience the same issue as it might help me at least make the relevant documentation more useful/easier to find :slight_smile:

Thank you for all the help you give; these forums are extremely useful.

I am a new convert from Sibelius I-VI, and am delighted that the frustrations that I had for years with that program are no longer around.

This solved the grand staff issue for me, but when I try and record into two voices, say a violin duo or the violin parts of a string quintet, it still all ends up on one stave. Do I have to approach tis differently, or am I just missing something?

Thanks again, Nick

Welcome to the forum, Nick. You cannot currently record into two separate instruments at the same time with real-time recording, but this is something we’d like to expand upon in future versions.

Slightly off the topic, but are there any plans for a smart split point, such as that available in Mainstage?

No concrete plans, but it’s certainly something we expect to look at in future.

Thanks Daniel. It could be a big timesaver in Dorico.

Thank you, Daniel, for your help.

Also, when I record something into both staves of the piano, I can’t then copy/paste it into two separate other voices (like 2 string parts). I presume that is related. But if I change the midi split point, I can record, say, two string parts simultaneously into a piano part and then alt-M or -N them into the right place, which is a good work around.

Copying and pasting is per-instrument, not per stave, so if you try to copy and paste simultaneously from the two staves of a piano to another instrument, that instrument also needs to have two staves. If you need to copy from a piano to two separate violins, do the staves one at a time.

My midi split point is set to 60 (also tried resetting it to other values). When I step enter a chord on my midi keyboard, notes will be split, but the split point is not correct. If I enter RECORD mode and play the chords, everything gets recorded into the right hand. I assume, as a switcher from Sibelius to Dorico Pro that I’m doing something wrong.

I’ve also tried extending the caret into both right and left hands, but when entering chords, the MIDI split point is not honored.


Okay, after sending the above, of course, I saw Daniel’s comment about NOT invoking the caret That works for recording, but not for step entry as far as I can tell. I’m using the new Pitch-before-Duration option.


Kevin, you should certainly find that the split point you define on the Play page of Preferences takes effect when you are inputting with the caret spanning both staves of the piano; this definitely works for me (I just tried it to make sure).

Thanks Daniel, the split point is now working in STEP entry. I started a new project. And all seems good.