MIDI-input won't give VST output.

I got myself the new 9.5.30 update. In 9.5.21 or so everything worked perfectly.

When I connect my M-AUDIO Keystation 88es MIDI keyboard to my PC and start
Cubase and I try to play some VST with it, it doesn’t work.

On the left bar I explicitly tried “All MIDI inputs” and “M-AUDIO Keystation 88es” as input.
Both don’t work. On the downer right side I see that Cubase recognizes my MIDI activity
when I play something. But I get no sound. When I click a pattern and play it in a loop
I also get sound. So everything works perfect, except that I can’t play with my
MIDI keyboard.

In FL Studio playing and recording works fine. So what am I missing?

When I press F4 everything seems to be fine. Don’t know if that is problem related.

Has it something to do with: “Studio > Studio Settings > MIDI > MIDI-connection-settings”???

What did I or the update change though?

Hi,

Can you see the MIDI activity in the virtual Instrument? Most often, there is any “LED” of incoming MIDI data. Can you see it blinking?

Can you see the VU meters in the instrument? Can you see the VU meters in the Instrument track?

Could you share a screenshot of the MIDI Connection Settings? And a screenshot from the virtual Instrument?

On the Track with the VSTi you want to hear, make sure to enable the Monitor button.

https://picload.org/image/dowwcgow/01.png

https://picload.org/image/dowwcglr/02.png

https://picload.org/image/dowwcgla/03.png

https://picload.org/image/dowwcgll/04.png

Hi,

On the screenshots, I can see, there is an even output from the Instrument track, and there is even an output from Cubase (on the Transport Panel the most right VU meters). So it seems, you don’t get a sound out of Cubase.

He is getting audio in those screencaps BECAUSE he is playing back. The transport play button is lit.
On the last screencap he has not pressed play and has record monitor on but there is no audio.

Make sure you didn’t somehow set midi filter in prefs not to allow the channel the ES sends on.

Yes, you’re right with the playback and all.

Where can I find that MIDI Filter thingy? As you can see, I have a German UI.
Do you mean?:
Studio < Studio-Settings < MIDI < MIDI-Connection-Settings?
Like the window that you guys can see in one of my 4 posts?

Datei/programmeinstellungen/Midi-Filter.

FOR CRYING OUT LOUD! WHY CAN’T I THANK YOU FOR THAT POST‽‽‽
They should integrate that feature.

I got into the program settings, then “MIDI”, then “MIDI-Filter”. Turns out
I made a tick in every window. I suppose my logic back then was:
“If I make a tick every where, this can’t turn out bad”.

I reset the settings and everything is working again. Thanks for everyone especially you grim!
How did you know about this? Learning and trying your self or did you see a seminar for the software?

Everything’s fine again.