MIDI Insert - Transformer - Not Working


The Midi Transformer works on a single midi/instrument track. Once I add a transformer insert on any additional tracks they don’t work. Only the transformer on the first track works.

Steps to replicate:
1 - Create a midi track
2 - Add a Transformer MIDI Insert
3 - Set the Transformer to the parameters below
–It works–
4 - Add the same transformer insert to any other MIDI or Instrument track, same parameters

RESULT: The additional transformer inserts do not work. Only the first one does.
EXPECTATION: The insert should work for any track it is added to.

USER BEHAVIOR: I’m doing this to lower the midi cc volume for a Trumpet 2 part automatically.
FEATURE SUGGESTION: The MIDI Modifier can compress Velocities. It should also have an option to compress midi volume.


  • Type Is - Equal - Controller - And
  • MIDI Controller No. (Value 2) - Equal - 7


  • Value 2 - Multiply By - 0.75

Was that just a typo, or are you really setting Value 2?.. it should of course be Value 1 in that line.

Anyways, to test, I used a slightly different parameter (one that would be obviously audible… I set both Transformers to Transpose by one semitone). It worked fine here.
Can you confirm that it is still not working if you give it that same “stress test” (to make sure the problem is not unique to CC#7)?


In short, I’ve confirmed it’s a bug.

It in fact should be Value 2, as I am trying to low the cc value, not the cc number.
Value 1 is defined as the “midi controller no.” I am not trying to change this.
Value 2 is defined as the “midi controller value” which I am trying to change.

There is a clear audible result if I multiply by 0.1 = the trumpet 2 part is considerably quieter than it is when I disable the insert. However, once I apply the same insert and parameters to any other tracks, it doesn’t work. And for the record, The Action Target also needs to be Value 2, in order to multiply the midi volume.

I’m using it correctly and it does work on 1 track, but I can’t use the transformer this way on other tracks of any kind with any instrument. During my day job I test software and report bugs. It’s not my primary roll, but I am familiar with testing methods, regression testing, glass box testing, etc. My point is not to be defensive, just say that I at least understand what I’m trying to accomplish and what I’m doing as a user, etc. This is definitely a bug unless for some reason Steinberg only wants the midi transformer to work on one track and only for editing just the cc7 value (which would be quite odd and inconsistent) lol. If that were actually true it would be a considerable design bug at very least because it wouldn’t do what any user would expect. If it works for one track, why not others? What reason would justify this? :open_mouth: In any case, thanks for the update.

Hope that helps!

Sorry, I can’t repro here either. I tried:

Create an instrument track Halion SE Guitar (GM 027)
insert 8 quarter notes
add some nodes of CC Value 7.
add a Transfomer preset:

Type is Controller
Value 7 = CC7 (Main Volume)

Value 2 Multiply by .75

Works. Then I added other instrument tracks and instantiated the same Transformer preset on each.

All works.

(The Issue Reports forum requires manual approval of each response- to facilitate discussion I’ll move this to Miscellaneous for the moment- if someone can reproduce this I’ll move it back to Issue reports)

Yes, I know you want to transform Value 2, but you wrote “Value 2” in the Input filter line… even though you labelled it “MIDI Controller No.” (which is why I asked if it was a typo :wink: ). If you really had put “Value 2” there, it would multiply any controller whose current value (i.e. value 2) is 7, by 0.25


  • Type Is - Equal - Controller - And
  • MIDI Controller No. > (Value 2) > - Equal - 7


  • Value 2 - Multiply By - 0.75

Works fine here

Thanks everyone and thanks Vic for clarifying. :wink: It’s a bit frustrating that no one can replicate this but I guess that’s a good thing, and life.

AMD FX 9370
Mobo: ga-990fxa-ud3
Win 7 x64
Cubase x64
First Track (midi) = Pass
Instrument Tracks = Fail
Midi Tracks = Fail

Not sure if it helps but in case anyone else reports this, I’ve added more info. I’ll be getting a new machine soon anyway so hopefully a new install will resolve this. If not, believe me… I’ll be posting more info. :wink: