Midi Inserts Bypass buggy

Win10, 12.0.60

Bypass status of midi inserts does not alway work correctly. For example if they are manually enabled/disabled via a Logical Editor Preset + Midi Remote and then different tracks are selected or copied (as in working with multiple tracks, switching between them) then sometimes it occurs that the visual indicator in the top line of ‘midi insert effects’ in the inspector shows a blue symbol for ENABLED but instead the inserts are disabled and vice versa. It helps to change the status (like switching them ON or OFF) but all commands (whether set to ON or OFF in the logical editor) just TOGGLE the status (without changing the display).

Sounds complicated, i know, but basically it’s pretty simple.

For this to gain any traction I would advise you write a repeatable step-by-step that others can follow that induces this issue.


Do you have any steel by step way to reproduce it, please?

Ok, will do my best.

  • Create empty project.

  • Add Midi track

  • Open Midi Insert FX section in inspector and add MIDI monitor to any slot (the MIDI monitor is just to make it easier to see stuff but it applies to any MIDI fx)

  • Play midi keyboard to see incoming notes in the MIDI monitor
    So far so good.

  • Open Project Logical Editor / Settings and add new setup:
    Have to translate from German so settings may be named a bit differently.

  • Set Upper area (filter target): STATUS / IS SET / SELECTED

  • Set Lower area (action target): TRACK OPERATION / INSERTS BYPASS / ACTIVATE

  • Click Apply. As expected the MIDI inserts are now bypassed and the bypass indicator turns from blue to yellow. (Play midi keyboard to check- no incoming notes in the MIDI monitor.)

  • Click Apply again. Now the bypass indicator stays yellow BUT the MIDI inserts are (unexpectedly) active again. (Play midi keyboard to check and see notes being displayed in the MIDI monitor)

Problem: We just ACTIVATED the bypass switch twice. I would expect the inserts to still be inactive.
Same thing happens with the DEACTIVATE setting.
First time these settings are applied they to do what is expected. But the second time they TOGGLE (without changing the visual indicator.) There IS also a toggle option in the logical editor but this was not used here.

Video 1: Setup + Toggle (everything works fine):

Video 2: (De)activate bypass bug

Yes, I can replicate this one too, seems like instead of enabling/disabling we get toggling. At the same time, the audio inserts work as expected and this makes me wonder whether this command was set to target just the audio inserts because I don’t see why audio/midi inserts should be byPassed with the same command at the same time.


Reported to Steinberg. Thank you.

1 Like