Midi instruments go out of tune?

This is strange…Im using a midi instrument plugin…if played without recording sounds good then when I record it on a track sounds great…but on playback some of the notes sound flat???..anyone experince this problem?..its not my controller on pitch bend…I had this problem with the vst amp of steinberg. Is this a known bug?..used same plug in on cubase 7 no problem…dont know what to make of it…this plugin works well in other programs Pro tools, logic pro x…but in cubase pro 9…it goes out…

I’m noticing this with Halion 6. This is a genuine issue:
I mixed down a (monophonic) Hal 6 bass track to audio and ran it through variaudio --> pitch & warp. Several of the notes were obviously out of tune.

This is sad when its in their playback system and not in their earlier versions of cubase… How long before there is a fix on this? I do alot of midi work and when one midi fails making the song sound out of tune…I got to use their competor program to redo the project… I also get audio drop out when playing back my material when i first use it…but it stops after one pass…this should have also been address cos when your audio has drop outs its part of their playback system. And now I see that using a midi program it goes out of tune! Hopefully on the next patch fix they will have fixed both problems.

Hi

@uniglobe2, could you share your project with me via PM (and Dropbox), please? Barryjames cannot share his projects, and I would like to reproduce it.

Thanks

@Barryjames— my issue appears to be the same in Cubase Pro 8.5.10 and in 9.0.20.
@Martin, I am sharing a dropbox folder with you. Please check pm.

Workarounds—on my most recent project I used these workarounds on the two tracks with the issue—

  • in the first case the problem was with the HALion bassline only. I mixed it down to its own track and used variaudio to fix it.
  • in the second case several HALion channels were out of tune. Luckily this was an all-synth song. I saved the project as a midi file, opened a new project and recreated the whole song using Retrologue instances.

—i’m on to a new project and unfortunately I’ve already run into this tuning issue on two songs.

It’s an issue only a few of us are having, so I understand why there’s not been an immediate fix, but as you can imagine, it is scary not being able to rely on your DAW / VSTi setup to stay in tune!

1 Like

Hello folks,
This probably has nothing to do with your issue, but I was having problems with vsti’s going out of tune on all the DAW’s I use. (Cubase 9, Reaper, and FL Studio Producer). Vsti’s were randomly going out of tune. I use a Korg microKontrol as a controller. I discovered that the joystick was getting a little dodgy and would transpose notes up or down. If I happened to be recording, it would record the cc data. I disabled the joystick in the scenes I use for each DAW, and the issue went away. Once again, probably nothing to do withyour issue, but doesn’t hurt to check everything.

Same Issue –

OK, this has now happened on my system. Halion Sonic SE and other Steinberg Instruments are out of tune.

I’ve not found any way to correct this. The Halion is flat by some number of cents, however, it can not just be tuned down by a few cents to correct it. It’s not a consistent error. Some patches are worse than others, but the entire instrument is suddenly not in tune.

I’m really at a loss. I have a very basic set of instruments, some from Steinberg, others from Air Music and various Rack instruments. It seems that the HSSE is internally in tune, the stand alone version does not seem out of tune, but loaded into a project, HSSE it is not at 440. I’m not a Piano Tuner, but a late family member of mine was a Registered Piano Technician with the Piano Tuner’s Guild, so after years of time with him, I do know what an in tune instrument sounds like and HSSE is not in tune. As far as the other instruments go, Retrologue also seems out of tune. I’ve mostly noticed this with HSSE Ver 3 and it just manifested this problem a few days ago. Why? I have no idea. Nothing was changed on the computer system.

All are slightly flat, but not by a consistent number of cents. This is a real show stopper.

I’ve carefully checked and rechecked my settings and preferences. I’m at a loss. I’ve not yet reset preferences to see if that corrects things. I hate having to do that.

I noticed this two days and it’s very, very much of a real issue. Something has gone very wrong. :frowning:

Please advise.

1 Like

Hi,

You and others posted about this back in April and since then have you found any way to correct this. This problem has just showed up on my system. It’s a real show stopper as far as I’m concerned. I can’t cope with an out of tune instrument. Any word about this?

Really, I was just going to trial Halion 6.

Has anyone who has observed this phenomenon come up with either a cast iron way of reproducing it and/or solving it?

I’ve not witnessed it myself (but am not claiming it’s not an issue) during my Halion 6 trial (now on week 3).

I don’t think I’d know how to reproduce this problem. It’s a real mystery. I’ve not yet tried a reset of Preferences and that often corrects the odd Cubase error that shows up from time to time. I was hoping to hear from someone about this before I took that step.

I only have Halison SE/3, so perhaps this is not an issue with the other instruments in the family. When I load HSSE3 as a stand alone, it seems to be in tune, but when it is placed in a Project – and 99.9 per cent of my projects include at least one instance of the instrument – it is out of tune. So, as it is now almost of not every project I’ve created over the last two years is now out of tune.

It just showed up out of blue and I have no insights into how or why the instruments went out of tune. In addition, I think there is also tuning problems with other Steinberg instruments now as well. It isn’t only HSSE. Since this only showed up about 48 hours ago I haven’t fully checked everything. In HSSE 3 all the patches sound flat, but not by a set number of cents. The whole tuning sounds wrong but is consistently flat but can not be re-tuned with the tuning slider. It is the instrument’s tuning itself which has gone wrong. Nice Strats sound off, the great sounding saxes sound strange and flat, pianos are all flat, but, again, it’s not a consistent flatness. basses are flat and they all are, apparently, by different amount.

I posted on the Issue section of the Halion forum and I’d really like to hear from someone in tech support about this. I’ve not yet opened a ticket on this.

During the last updates something called “impulses” was updated. I wonder if that, perhaps, has something to do with this? That’s a total guess on my part. I have no idea what the “impulses” update was all about, I just noticed it taking place during the update from HSSE 2 to HSSE 3.

I hope someone has some assistance with this.

My best,
Stephen

Thanks for your in-depth reply Stephen…as you say I hope we get an answer. I shall continue to monitor to see if I too succumb.

The only thing I did “new” with Cubase before this happened was attempting to create and import Track Archives. I don’t think there’s any connection with that and this tuning issue.

I hope there’s some kind of solution to this or perhaps it will just somehow correct itself. I’ll bite the bullet and reset preferences and hope for the best.

I notice the out of tune, too…but I think I found out why…are you using any effects?..especially the eq ge10?..if so use only the frequency eq…not the ge10…I found that the ge10 was making my midi go out of tune…

The out of tune issue is not related to EQ. The instruments are out of tune in default settings without any effects at all. Something is really not OK here.

Today we are pleased to announce the immediate availability of the hotfix update versions 6.0.15 for HALion and 3.0.15 for HALion Sonic and HALion Sonic SE.

An issue has been resolved where Zones were played detuned with unison disabled, if a unison detune value was set.

Download HALion 6.0.15

Download HALion Sonic 3.0.15

Download HALion Sonic SE 3.0.15