MIDI issues - Casio AP-45

I am having issues when connecting my Casio AP-45 digital piano to cubase. The piano is not detected and it is not functioning at all.

I have a MIDI keyboard (M-Audio) that works with USB and MIDI out. I tried to connect the M-Audio keyboard with the USB-MIDI cable I am using to connect my digital piano and it worked perfectly.

Now, what I waant to know is if there is an specific setup or change that I need to do on my computer in order to have this digital piano working with Cubase.

All the configurations were made on the control panel for the keyboards be working with Cubase and still no response with the digital piano.

Don’ t use devices that do not work at all, Use devicesv that work…

I am only using MIDI cables for my keyboard/expanders gear. From this, and guessing that your piano is also connected to your Audio/MIDI interface with a MIDI cable, few things to check (here, I suppose that you have an integrated MIDI-audio device with a dedicated ASIO driver for it to be used by Cubase) :

  1. In the ‘Device setup’ window, ‘MIDI/MIDI port setup’, be sure that there is at least one MIDI in port that is visible and active. If not, there is a problem in your setup : check in the ‘VST audio system’ that Cubase is working with an ASIO driver (or, at least and even if it’s not recommended, would it only be for latency reasons, a ‘Generic low latency’ or an ‘ASIO full duplex’ one).

  2. Be sure that this port is used in the track inspector ‘Input routing’ field of the MIDI/Instrument track used to record/play the MIDI data in Cubase.

  3. At this point, do you recieve any incoming MIDI data (check the MIDI meter of the transport bar) ? If not, try to use as MIDI insert the ‘MIDI monitor’ plug-in and see if there is any data displayed when playing your piano.

I am using a Focusrite 2i2 and changed the latency settings for them to be at 5.xx.
This is not a latency issue, i tried to connect an M-Audio Keystation 49e with the same MIDI cable, and Cubase is recognizing the keyboard.

The issue is with the Digital piano (AP-45). When attempting to connect the piano, Cubase does not recognize the keys I am pressing on it, nevertheless, it recognizes the MIDI-USB cable when going into the MIDI setup (the MIDI-USB is being recognized on the computer and on Cubase as well).

So basically the issue is with the piano, not with the cable.

I didn’t say that it was a latency issue, I said that using a driver different than the dedicated ASIO one for your Focusrite could lead to this. What I don’t get, as the Focusrite doesn’t seem to have MIDI features, is where your MIDI/USB cable is connected on your DAW and how it is setup in Cubase.

But indeed, if there is no incoming MIDI data recognized in Cubase and if you are sure that the MIDI/USB cable is correctly set up, then something is missing in your piano settings, which prevents him from sending the MIDI relevent messages.

Sorry to not be more helpful than that…