Midi Jitter during playback !!!

Hi guys,
I recently found out there is problem with midi playback inside my Cubase. Basically every time Cubase plays midi tracks differently. It seems this cause by midi jitter and it plays notes early or late by milliseconds. This is noticeable when I play mixture of audio and midi tracks.

I ran a null-test to make sure it’s a problem with midi playback and not the audio, so I created a “Groove Agent One” instrumental track and programmed a simple beat at 120 BPM. Then I exported the track as an audio and imported it back in and flipped the phase of the audio track. So in reality there shouldn’t be any sounds when I play them together. But I easily can hear drum parts are out of phase.
I’ve tested same thing in pro tools and everything seems to be fine. If jitter causes by my system why there is no problem in Pro tools?
This is a big issue for me when I have midis and audio tracks in a project. Or when I bounce Vst instruments as an audio and bring them back into the project.

This problem only occurs during the playback and not the final Audio mixdown. Also I’ve tested the same thing with Mbox2 and Presonus Firebox, so I guess this doesn’t cause by Audio Devices.

I’m running Cubase 5.5.2 and windows Xp sp3.

Any comments and help would be appreciated.

Thanks…

Midi jitter is a hardware issue. As Cubase is ok for most users the quickest way for you to fix this is to investigate that area of your system. However someone here might be able to help you but I’d think you would be better off in the hardware section.

if its hardware problem, why there is no internal jitter inside pro tools??

Depends possibly on what type of pro tools system you have. If it is HD or one of the external boxes, it would be different hardware.

It it is the new pro tools 9 running fully as software, you’ve got a good point.

Como

I’m Running PT 7.4 with Mbox2

And do you use the MBox2 with Cubase as well?

If so, again, good point … since there doesn’t appear that there would be any difference in your basic hardware in your computer or your audio interface.

But beyond validating your logic, I don’t have any answer.

Como

If it’s a Cubase problem ONLY why do very few other Cubase users complain about this?
It does seem that in most posts like this that the user answer is usually “It doesbn’t happen using X or Y software” etc. This makes me think that a Windows setting made for the other software may be something that disagrees with the settings needed for Cubase to work.
However, anyone with a solution would really need a lot more detail in the post to make an attempt at fixing this particular problem.
I mean, how do we know that there might be jitter in the Pro Tools if it had been installed after Cubase rather than vice versa? Many unknown variables.

Would you guys download this null-test project file and see if the problem occurs on your system too?? and then report your results back with your system info please.

http://www.megaupload.com/?d=XBKFOVYZ

There are 3 markers:

I’ve created a “HalionOne Gm drum” instrumental track and programmed a simple beat. Then I exported the track as an audio and imported it back in and flipped the phase of the audio channel. (Marker 1)

When I play them together, I easily can hear drum parts are out of phase. so this is the problem and the null-test is failed here. I recorded the playback using the cubase internal routing… (Marker2)

It seems it happens only during playback and not during exporting the Audio as a mixdown. I exported same midi track twice and played both Audio mixdown together with one of them has flip phase on, and there was no sounds. (Marker 3)


Basically If you can NOT hear anything during Marker 1 loop, your system is fine.


Thanks

I ran your test.

Export audio produced a low level tinny response which was constant over time (same as your test)
Export audio in realtime gave me similar tonal response, but variable over time - it would disappear and reappear randomly

Freezing the VST prior to export produced silence ie. perfect cancellation. So I would conclude that it is MIDI trigger variation in the vst that is the cause.

I noticed that moving one of the phaze cancelling tracks by .04ms produced similar tonal results, so the error is extremely small ie. 1 sample. So I won’t be losing any sleep over it.

P

C6.01 Win Xp Pro

Thanks Parrotspain for your feedback.
Also I ran a internal midi test using “Maple virtual midi cable”. Here is a screen shot. This shows cubase triggers midi notes differently everytime. :frowning:
Midi Cubase.jpg

Those who say midi drums or midi instruments in general sound robotic are hereby owned :laughing:

Have you by any chance set your Audio Priority (Device Setup) to “Boost”? Though I’m pretty sure that’s not the case. Just a thought.

Could be close as some old drum machines (Sequential Circuits) did have a deliberate and subtle offset.
If you use the drums from another source like the Halions do they suffer the same timing deviants?

Also, if you go into the GA settings what happens if you alter the Attack settings? I have a suspicion that these may play a part in the effects you are noticing. I can only think at the moment that they would certainly have an effect on the positioning of the instruments’ leading edges.
If the GA1 has some note deviation built in then the part recorded to Audio would stay as it was whan recorded but the GA would shift some. I would expect this to be random rather than constant and, as observed by Parrotspain, that it would not be much for the usual musical purposes.

No, it sets to “Normal”, although I tried the “Boost” option and it didn’t change anything.


Well This does NOT cause by VSTs. In above example I only used 2 midi tracks, one is sending notes and other one is receiving them during playback. Cubase internal engine creates these time variations.

Well I would expect that Boost would make things worse.

What authority do you have that it’s definitely not a VST causing the timing difference?

Your last statement is somewhat ambiguous.
2 midi tracks. One sending. To where? One receiving. From where? Each other?

I suppose the kernel here is: What is this preventing you from doing that countless other users do every day?
Do you need a greater level of accuracy for something?

It seems it happens only during playback and not during exporting the Audio as a mixdown. I exported same midi track twice and played both Audio mixdown together with one of them has flip phase on, and there was no sounds. (Marker 3)

See. This is what I would expect and points to the timing in Cubase to be ok. It also means that the timing inside the VST records to audio constantly. Both are generated by the midi engine (unless you just copied one track) so the midi engine is constant at least as proved by these recordings nulling. (exporting the midi track effectively “plays” it ie: it is not static)
What I would expect in a sample based drum machine is that there will be timing discrepancies due to the sample placements, attack position and FX generated within the VSTi and, like any other synth recording, trying to null against the original midi track will never work as the recording will be fixed while the synth will modulate.

Yes from each other. As I mentioned above I used " Maple virtual midi cable" to rout 2 midi channels. There are time variations without using any VSTs, which is kind of weird.

Have you used “Midiox” (freeware utility) to check the midi in / outs? And are you using the Maple virtual cables as your midi inputs in Cubase?
I know you are routing to test but did you record the problem part with it?

Just a couple of thoughts based on a quick mention of the two in Sound on Sound.

What happens if you input / draw the drum data to the GA1 track directly with the mouse rather than keyboard? Same effect?

BUMP! This is horrible, this causes comb filtering.

I get the exact same effect under Cubase 5.5.2, 6.0.2, and 6.0.3 all 32 bit. when I freeze the track its in sync with the mixed down audio track, both realtime and not realtime.

Anyone find a solution?

Might be an idea to start your own thread rather than be ignored because no-one gets to the bottom of this one.

Why do you think Cubase causes the comb filtering?
How does it affect what you do with Cubase on a practical level?
Also, why do you think no-one else gets it?

I was under the impression that this was a well known fact… Along with the automation being similarly inaccurate. I thought that it stemmed from the buffer size setting in some way, and at one point there was a suggestion that to increase the accuracy you should export at a lower buffer size.

Anyway, I confirm that that for me, cloning a vst midi track causes continually variable phasing problems, and playing the VST along with an export also does the same thing.

It would be nice if the midi timing was sample accurate that’s for sure but that’s not what I’ve observed so far - although I’ve not checked recently.

As there was mention of PT earlier, their manual suggests the same thing re automation accuracy but I don’t know about midi accuracy, not tried it.

Mike.