Midi key commands for markers.

I can use an external midi controller for most of the key commands.

However - why can’t I use a midi keyboard to drop different types of markers into the active window?

In customize commands - there is no option to use a midi controller to ‘insert’ markers.

As I drop different kinds of markers all the time - this would be really useful.

Also - I need a key command to ‘Rename’ the active marker - or the first marker of a marker pair.

Thanks

However - why can’t I use a midi keyboard to drop different types of markers into the active window?
In customize commands - there is no option to use a midi controller to ‘insert’ markers.

Yes there is:
2012-08-16_17-36-35.png

Also - I need a key command to ‘Rename’ the active marker - or the first marker of a marker pair.

More tricky as there can be multiple markers. How WaveLab can know the marker you want to edit? You need eg. to point and click on the marker (then MIDI control does not make sense), or use the keyboard to edit the list (and then Enter is the shortcut to edit the name).

Thanks PG

I’m trying to drop markers in the active file

The example above is only for the montage?

So I can’t see how this is possible on the active audio file?

The same is possible for the active audio file.

Got it working now

There is an additional ‘Customize Commands’ menu from the separate ‘markers’ window

I was looking via: Options> Customize commands - where Insert ‘create’ markers doesn’t exist.
create_markers_working.jpg

Does this also work for ‘drop marker’ while using the recording dialog?

For example, say I provide a narrator with a midi control button to mark places that they think need editing so that while recording, they can mark places that need further review.

Nevermind, I figured it out. So it turns out it is possible to set shortcuts, including ‘drop marker’, on the record dialog independently. It took me a while to find it though.

To anyone who is interested. Open up the recording dialog, Go to the Options tab and just above the meter there’s a little man icon with ‘Shortcuts’ to the right of it. It’s off-center to the right.

That works for me.