Midi Keyboard does not enter notes

Hi All,
I work on a 5,1 Mac Pro Mojave with Note Performer and an Yamaha CP33 keyboard which I use all the time for DAW composition in cubase. Since I also installed Dorico on this computer the program does ignore any note entry with the midi keyboard. I hear the sounds when I play but it does not write. Entering with the computer keyboard is no problem. I tried all settings that I know of but no luck.
Can anybody help what is going wrong there? Thanks for help.

Have you checked your Program Preferences?


Thank you for the reply. Yes it is enabled of course. The answer isn’t that easy I’m afraid. I tried everything I could find. I work usually on a PC when I write scores. No problem there. But I need to write sometimes at my DAW computer which is the MacPro. And there it just doesn’t write the music.
Just made a reinstall but it didn’t help. Same problem.

And is your MIDI keyboard listed when you press the ‘MIDI Input Devices’ button? Do you have Cubase or some other application open, that maybe exclusively grab the MIDI ports?

Yes listed. Cubase is not open. I mean it triggers the sounds. I can play in Dorico but it does not write. Tried it also with another controller. A Roland A-500 and its the same.
I´m not a newby. I composed and arranged in Sibelius for years. Program in Cubase, did some films. So I wouldn’t ask if I didn’t have checked the obvious.
Its really strange.
Btw I´m on Dorico 3.1

Hi. Not sure it helps but it’s worth asking: when you play with your keyboard, do you have a green flickering dot on the bottom right corner of Dorico’s window? It indicates that MIDI data is received indeed.

Thank you so far for the answers.
I have a green light on the bottom right. It doesn’t flicker just lights.And I assume I wouldn’t hear a sound if Dorico wouldn’t receive midi datas.
There is strange behavior anyway. When I start Dorico and want to play/write it does nothing in the beginning. Then I fiddle around at the play menu open up Note Performer and suddenly I have a sound and can play with the keyboard. But no writing at all. Never experienced something like that.
I would appreciate very much if somebody has an idea.
What I already did is restarting, reinstalling.

If you want to use NotePerformer, you must use Play mode> Play menu > Playback Template… and choose NotePerformer there. There’s no way to configure NotePerformer manually. Hopefully this should solve your problem!

Gentlemen, thank you very much. Problem is solved. The RME Soundcard used the same midi port1 as my keyboard. I only found out about it when I went to the play menu and checked Midi Instruments. Disabling in the sound card midi output in the options menu suddenly brought the keyboard to writing mode. Strange and really not obvious . For me at least. Learned something again.
Thanks again.

Well the problem wasn’t related to Note Performer obviously. But thank you. I have NP as my default.

I’m on Windows so perhaps different than Mac, but I created virtual MIDI ports so each program requiring MIDI can have its own port, then use another program to route the signal from the MIDI keyboard to each port. This way multiple programs can all receive a signal from the MIDI keyboard at the same time. I don’t know how to configure that on a MAC but I assume it wouldn’t be too difficult.

As soon as you said you had a solid green MIDI light, I suspected you had a feedback loop (a known situation) but by then you had already found the problem. Glad it is fixed.