Midi keyboard doesn't trigger a sound form a keyboard (but it does when I use a mouse)

I’m experiencing an issue with Halion 6 when I using it without DAW as a separate program and with DAW (Reaper).

I’ve set up Keystation61 MK3 as a Midi controller. The problem - in standalone version it doesn’t reflect any sound when I press the keys on it. It simply doesn’t react.

Though when I press keys on the virtual midi keyboard with my mouse, it is working. I don’t understand what is causing the issue.

The midi keyboard is working well with KONTAKT, I can upload a virtual instrument and play.

I thought the issue may lie in external sound card. I’ve updated the latest driver but it didn’t help. I tried to record it using KONTAKT and it was fine. With Halion it recorded the Midi parts but again no sound

I would appreciate any help from your side, thank you.

I would check the midi port and midi channel.

Is your midi keyboard sending signal on channel 1?

Thank you for your reply.
For now “all” is selected, so there is no concrete MIDI channel

In the top left corner of your screenshot there is a midi activity led icon. Does it light up when you press key on your midi keyboard?

Can you change the midi channel of your midi keyboard? When using Halion standalone midi channel does matter. Your loaded program is set to channel 1. If your midi keyboard sends midi data on other channel it will not play.

That’s why I suggested to check the midi channel (on your midi keyboard).

Yes, right, the LED lights up, when I press key on my midi keyboard. The channel is not specofoc, set to “all”.

I changed midi channel as you advised. After that the led didn’t light up and I still don’t hear the sound.
What worries me I hear the sound when I click on the keyboard with my mouse. Though Halion sees the real midi keyboard and receiving signal from it, it doesn’t emit a sound. That’s strange.

But you changed the channel on your midi keyboard? Not in Halion settings. The settings in your picture look correct.

Oh, I didn’t know about it

I changed it and it worked, thank you very much for your help!

The instruction I followed:

Can I change the MIDI channel on the Keystation MK3?

Yes! It’s easy:

  1. Press the Advanced button to engage Edit mode.
  2. Press one of the 16 Channel keys (D2 to E4) to choose a MIDI channel.