Midi keyboard, input odd

Hi all,

Using v13 on Mac Ventura. My DGX670 keyboard connects via midi with no problem.

However, when creating a score with the keyboard input, populating the score, Cubase recognises my keyboard keys a full octave out. For instance, play a C4 and it is annotated as C3 - same across the whole keyboard.

I hope that makes sense.

Any ideas, anyone, please?



Most probably, you can easily transpose your MIDI keyboard.

The name could be different. At some systems the MIDI Note Pitch 0 = C-2, at other systems the MIDI Note Pitch 0 = C-1.


Not sure how you do this. In Reaper, a C4 note is correct, same with Garageband. In Cubase, a C4 registers as C3.

I don’t need to transpose my keyboard in other DAWs, just Cubase?


I expect it’s the same Pitch (Note Number), just a different name. A I right?

As I said, there are two standards. Cubase starts at C-2.


If I play my Yamaha keyboard with, for instance, Reaper., the notes are played/recognised correctly. Middle C (C4) registers as C4. Cubase gets it wrong. C4 becomes C3 - a whole Octave out.


Again, it’s not wrong MIDI Standard allows both options. The middle C (Pitch Nr. 60) can be either C3 or C4. Both options are equal.

And my question again:
Do you get MIDI Note Pitch = 60?

Sorry, I just don’t get this. One DAW recognises a middle C the other doesn’t. How can they be the same?


They can be the same (Pitch 60), just using different names.

This makes no sense. When using the score editor and using my keyboard for input - it is useless if the score transcribes a C3 when a C4 is played.


Could you please answer: Are you talking about Pitch 60 in all cases?

Middle C should always be MIDI Note Number 60 no matter if you use a naming convention that calls it C3 or C4. It’s just 2 different measuring scales. Neither is right or wrong, they are just different. Like how the same temperature will be different when using Fahrenheit or Celsius.

MIDI only cares about the Note Number, it doesn’t care if you call it C4 or Charles.


How do I see the note number?


In the Preferences > Event Display > Chords & Pitches > Naming Format. You can change it to MIDI + MIDI Note Number, to see both, the name and the Note Number.

Thanks - got that. C4 = 72. C3=60. Therefore a whole octave apart. This, for me, renders Cubase note input into a score via the midi keyboard, un-usable. When I play C$, the score should show a C4, not a C3.


You don’t play C4, you play MIDI Note Number 72.

Semantics. When I play, the score should, accurately, show what was played - it doesn’t. Never mind, Reaper can do it, with no issues. TY.

Out of curiosity are you playing back the internal sounds from your keyboard ?
Best regards


Also make sure, your keyboard is not transposed.

Not transposed. Using the keyboard as a midi controller.