midi keyboard not connected

I have this annoying problem… that often when I start Cubase, and I have midi keyboard (korg microkey) already connected to usb, that inside Cubase I don’t see or hear any signal coming out from the keyboard. Normally I should see some signal coming at least in a mixer, but not now with this case. If I go to Device Setup/MIDI port setup, I see that Microkey is selected and Active + “in all MIDI inputs”. So what’s the problem? Do I really need to just restart Cubase to get the keyboard working? or is there somewhere inside Cubase some place where to update midi signal information or something like that?

You don’t say what version of Cubase or what computer OS you have but, maybe your issue (which seems opposite to this?) is somehow related to the issue posted in the link that happened on versions of Cubase prior to CB9 running on a Windows PC. So maybe your keyboard was connected but the PC did not “recognize” it prior to starting CB?

https://www.steinberg.net/forums/viewtopic.php?f=228&t=74134&hilit=Recognize

Also… Here is a method I originally posted that may help you. Remember this is for CB versions older than CB9 running on a Windows computer.

“For Windows O/S: Here is a way to restart a USB midi device that was plugged in before starting Cubase and was running properly but somehow got disconnected during the session.

Once you discover your USB is disconnected and not working do the following procedure:

  1. Shut off your USB midi device
  2. Re-plugin your USB midi device
  3. Turn on your USB midi device
  4. Go to Devices>Device Setup…>MIDI Port Setup
  5. Find your USB midi device in the list and uncheck the box “In ALL MIDI” this will make the state “Inactive”
  6. Recheck the “In ALL MIDI” box to make the state “Active”
  7. Hit OK

You would think just hitting the “reset” button instead of doing steps 5 & 6 would work but it doesn’t work for me. :question:


Regards. :sunglasses:

thanks for the answer. I didn’t see it until now. I actually stopped watching the thread for a while because I felt there’s nothing happening. So - thanks a lot! I’ll follow your instructions next time when the error happens.