midi keyboard not recognized

Hi Everyone!

I plugged my Casio CDP-s100 on my brand new HP - Spectre laptop (Windows home 10), the Computer recognized the midi device and installed the driver right away. However when I run Cubase the Software does not recognize the Keyboard as a midi, sometimes it is show on the ASIO Driver VST list - not currently showing there right now.

I’ve already tried:

-Turing local controls of my keyboard off, it didn’t’ change anything.
-Installing the driver from the Casio website, also didn’t work. I heard that new Casio keyboards does not need that, so I uninstalled, I’m using the driver that Windows installs automatically.
-Pugged my keyboard on a mac, it did work, so it is not a hardware issue.
-Also, I didn’t started Cubase before the Driver was installed.

Any suggestions about how to solve this?

Hi and welcome,

Can you see the MIDI input in any other MIDI software?

Just an idea: Try to connect the keyboard to a USB2-Plug. Some keyboards have occasionally issues with USB3-Plug.