Midi keyboard not working

I upgraded to Nuendo 12/13 from Cubase pro 12 and my midi keyboard is not working , but is working fine in Cubase pro 12/11.
Midi activity comes on when pressing the keys and when clicking on the on-screen piano key i do get sound.
I have Arturia, East west,Spitfire audio ,UVI, Native instruments and none of them work within Nuendo 12/13 but works fine other wise.
I have Motu M4 interface
Arturia MK2 61
Windows 10 version 22H2
32 Gig ram

Hi and welcome to the forum,

Please, double-check the Studio > Studio Setup > MIDI Ports Setup. Make sure, your keyboard is part of the ‘All MIDI Inputs’. Could you attach a screenshot of the window, please?

Here you can also see the MIDI Monitor for every single input. Activate the MIDI Monitor, can you see the incoming MIDI data, please?

Also double-check the Preferences > MIDI > MIDI Filter, please. By default only SysEx option is enabled for both Thru and Record. Make sure, no Channel is filtered out, please.

Thank you for responding, as you can see the settings are correct.
Any thing else I can try


We are talking about the KeyLab, right?

How does it look like in the Track Quick Controls and VST Quick Controls, please?

I thought I had an issue with my keyboard in Nuendo 13 but it turns out that when you add an instrument track, Midi Inputs is set to Not Connected by default. As soon as I changed it to All Midi Inputs I had lift off!

PS - Please tell me how to change default behaviour so that All Midi Inputs is selected by default as it was in previous versions!?

1 Like