MIDI keyboard notes drop out intermittently

Hi all,
I recorded some midi piano tracks back a few weeks ago using win 10 and Elements 11. They played perfectly when I last shut down the computer.
Today when I played them back some of the notes would cut out intermittently not always in the same place. I tried changing the buffer settings to no avail.
I rendered it to a wav file but it still did the same thing.
I deleted the tracks and tried to record new tracks but the midi keyboard notes were now cutting out intermittently. I have recorded many tracks using the midi keyboard and never had a problem before.
The only change is that I had to fit a new ssd drive as the old one failed and reinstall win 10 and Cubase etc.
Does anyone have any ideas?


I expect, you are using a Virtual Instrument. Try to increase the Buffer Size, please.

It makes no difference whatever buffer size I choose!
Maybe there’s something in the midi settings that has changed?


Where is the MIDI Out rooted to, please?

Ok I’ve been trying lots of combinations of what inputs and output routings should be. I need to set it back to what it should be?
Connected to Win 10 PC is UR22C through usb 3 port and Alexis Q mini midi keyboard through usb 2 port.
What settings should be showing with both inputs and outputs? ??
I’ve also made sure usb ports are not on power saving mode and deleted the sound, video driver and let windows reinstall the driver but midi note dropouts still occurring.

Anyone out there?


If this is the only project, where do you experience this, the project might be corrupted.

You can try to use the File > Back up project and open the new one. If this doesn’t help, you can try to Create Empty project and import the tracks from the original project.

No even when I open a new project and play the keyboard it cuts out intermittently.
What midi settings should be showing as default for the inputs and outputs with the Q mini and UR22C?


I expect, this is your MIDI keyboard. This doesn’t play any role while playback.

Higher Buffer Size prevents from drop-outs.