MIDI Keyboard Triggering Commands in Cubase 12

Hello everyone,
Greetings for the New Year!
First time writing here and need your help urgently.

I’m using Cubase 12 and do not use any MIDI Remote Controller as confirmed/shown by Key Editor.

I’m using a vintage Korg O1/W Pro keyboard for sequencing since day one.
Out of the blue, for the past 2 days, pressing some keys on the vintage Korg will trigger off certain commands in Cubase 12.
Eg. C4= Save or some keys will undo, nudge cursor, revert to old project etc.
I first discovered this as when I was inputting notes, I realized things will undo. Eg. Tracks moved back to where I moved them to.

I just realized, now, even opening and closing Cubase or any pop-up message from Cubase will trigger notes to the Korg O1/W. Some notes sustains and sometimes, it doesn’t.

Really difficult to work like that. I have no mapping or scripting (I don’t even know how to do that) and Key Editor confirms I have no remote controller attached.
The only other controller I have is a iCon Platform M+, which is turned off when I’m composing.

Any help and advice to resolve this will be much appreciated!

Regards,
Wei

The first thing I would try is to relaunch Cubase in ‘safe start’ mode and see if the issue persists. After this :

  • maybe check the Local on/off setting on the 01/W,
  • Be sure, in the Studio > Studio setup… window that all the items listed under Remote Devices (legacy) are not connected, this, for both MIDI input and MIDI output settings. Additionaly, check also that in the MIDI Remote manager window, there is no MIDI controllers ‘connected’.

Can’t think of another thing that could interviene, presently… :thinking:

HI cubik13,
Thanks for replying. I tried what you suggested:

  1. maybe check the Local on/off setting on the 01/W,
  • I hard reset my O1/W. Everything is fine, incl Local On/Off.
  1. Be sure, in the Studio > Studio setup… window that all the items listed under Remote Devices (legacy) are not connected, this, for both MIDI input and MIDI output settings.
  • Done. None connected.
  1. Additionaly, check also that in the MIDI Remote manager window, there is no MIDI controllers ‘connected’.
  • Done. None connected (see attached photo)

I tried with another synth, same problem.

  1. Safe Start mode
  • Only works when “Disable program preferences” is checked.
  • Solves the problem temporarily. Once I close Cubase and launch a project, problem comes back.

Conclusion: Source of problem has to be from Cubase, I just dunno what it is!

Gut feel is something to do with Preferences or Expression Mapping but I’m not even connected/mapped!

Any ideas anyone?
Much appreciated.

Double check the Remote devices. Maybe upload a screenshot of Studio Settings.

Do you have another midi program running at the same time? Check that if so.



Hi Steve,
Thanks for replying.
Above are screenshots of my studio setup.

Btw, what do you mean by “midi program running at the same time”, as in what sort of midi programs?

Thanks and regards.

Maybe I’m wrong, but I guess that @steve meant programs such as Bome MIDI Translator (MIDI real time messages processing) or MIDI LoopBe1/30 (added virtual MIDI ports).

Additionaly, could you provide us a screenshot of your Studio Setup > MIDI Remote pane ? Actually, it’s the more important one, in my view…

exactly, @cubic13. Also Vienna Instruments. @weiTPY should check everything.

Hi guys,

Thanks so much for advice. Still trouble shooting.

I don’t have any MIDI program running in the background. Not VSL either.
At the mean time, attached below is pic of my “Studio Setup > MIDI Remote pane “
& video of what’s going on.

Video:
Look at the mouse cursor in middle of screen at start of video.
When I press on my Korg keyboard:
C4 = Save project
C#4 = Revert
Eb3 = Channel Settings window
Last 4 keys on keyboard (E0-G0) = 4 audio tracks (not same tracks every time).

Video:

You won’t believe what happened. I tried everything including activating back old preferences thru Profile Manager, but nothing worked.

This problem even caused my usb MIDI connected Platform M+ mixer to produce a note when I touch any button on it.

Then I told my wife, who works in IT, and she said why don’t I just unplug the MIDI usb cable from keyb to PC and plug it in again (I only unplug the 5-pin MIDI ports end of MIDI cable when I tested with another keyboard, did not unplug usb end from PC).

I tried that and problem is gone.
Platform M+ also back to normal.
48 hours gone by now and everything is still working fine.

@cubic13 @steve
Thank you for your time and I’m sorry I can’t explain how Cubase 12 can suddenly go crazy like that and how it can be solved by just unplugging usb cable.

Source of problem is definitely Cubase 12.

Thanks again and Cheers,
Wei

she’s a keeper.

1 Like

I’m glad you fixed it, weiTPY. I am still suffering a similar issue here with Cubase 12x. When I press STOP (both on the computer keyboard and with the mouse pointer on the GUI stop button) a high note is sent out on all midi ports channels. It is a Catch 22 situation because since it is the STOP function I can not record the note to see which note it is. And since it triggers all connected instruments (virtual orchestra in VEP - sic!) it is impossible to hear the note. I would guess though that it is a high G#. Maybe it has to do with some (not yet found) setting to send out an All-Notes-Off by the STOP button press? I doubt that though since it is usually a CC123, and also a stupid idea; I much rather put my global notes-off on a special button that is not being used all the time… LOL :slight_smile: I get the same massive note bam from clicking on the time-line and when un-muting a muted track.

from the manual:
> * If you want Cubase to perform a MIDI reset on stop, select File > Preferences > MIDI and activate Reset on Stop.

I did check that and the RESET is not activated in my pref’s.

Hi per_boysen1,
Firstly, you might wanna try my unproven method of plugging and unplugging your midi cable from your controller and see if anything happens.

Secondly, Steve and cubic13 might be right. It could be a midi program like MIDI Ox running in the background at the same time with Cubase.
I realized this in hindsight.
I had some problem with my Platform M+ midi mixer. I called them and they fixed problem but they said, close the Platform M+ software after I loaded what I need, THEN start Cubase.
Somehow, I dunno why, you can’t run both at the same time.

Hope this helps.

Thank you. I have already excluded the possible reasons you mentioned and I am now setting up my workspace in Live 11, to get back into my workflow ASAP.