Midi keyboard volume way too quiet

Hi, I have Cubase 11 LE AI Elements and a Midistart Music 25 midi keyboard (USB input)
When I press keys on the keyboard they are way too quiet (can’t really hear them) and do not match the volumes set in the cubase project. If I turn the volume of my scarlett2i4 sound interface right up then the keyboard input can be heard - but if you then play the mix the volume is way to loud. In the past with my other midi keyboard it just played at the volume of the tracks in the mix. What can I do to adjust this? Is this possible with the version of Cubase I have? Or do I need another midi keyboard that will work with this?
Any help will be gratefully appreciated as this is driving me mad!
Thank you - Phil

Hi,

The Midistart Music 25 is just a MIDI keyboard. What sounds generator (instrument) do you use, please?

Hi there - it’s any of the instruments I use within Cubase. I’m not technically gifted but what I can see is that my tracks are set at 0 but when I hit the keys on the midi keyboard the highest it goes to is about -5 and only when I push the volume up with the slider in the mixer to the top does the volume then go to zero from the keyboard, but then that instrument in the mix is too loud. I’m used to the midi keyboard matching the volume of the track in the mix. Maybe I’m not explaining it too well! Any ideas?
Screenshot 2021-09-27 at 20.59.19|177x461

Record some MIDI to a track with the controller. Look at it in the MIDI List Editor. Are the note-on velocities consistently low?

I’ve seen this before. I’ve an old Yamaha KX76 controller that gives a max key velocity at about 50% (same with the old DX7). Not sure why it behaves that way but it always has. Would never produce more than a value of 64 for note-on velocity in my sequencers, no matter how hard I hammered the keys, and I never found settings in the keyboard to change this ‘velocity curve’ in the instrument itself, so Cubase to the rescue!

My solution is to use either Velocity Shift, or MIDI compression in the track inspector’s modulation section. Don’t forget these are real time settings and should be set post track, or to record as modded. Also read in your manual about ‘freezing’ MIDI tracks, so you understand the relationship between real time transforming, and the various ways you can ‘store’ this performance (original vs modded) to tracks.

https://steinberg.help/cubase_le/v11/en/cubase_nuendo/topics/midi_realtime_parameters_and_effects/midi_realtime_parameters_midi_modifiers_section_r.html

Note, many MIDI controller keyboards have somewhere in their options an adjustable velocity curve, sometimes it’s called a ‘touch’ setting. Some even have independent adjustments for black vs white keys. If this is your case and you fix it with your controller’s firmware/settings, then you might not need to shift or compress in the Cubase track inspector.

1 Like

PS, another thing I’ve run into when using external instruments (with their own internal tone generators). I.E. A Roland Fantom XR connected to audio inputs on the PC’s audio interface.

If it’s too soft, make sure it’s adjusted for a line level output, and check the gain stage in Cubase to get it pumping at the levels desired.

Hi - thank you for your reply. I’ve been away for a bit but will take a look at what you’ve said. It’s really annoying because I didn’t have this problem with my last MIDI keyboard but this one just won’t play ball. Makes it difficult to compose because the playback of the mix is significantly higher than the real time MIDI keyboard input and therefore one can’t ‘play along’ with it. I’ll report back in a few days…

In case it’s helpful to anybody else I bought I new MIDI controller in the end and the problem has gone away!

What did you get?